Toad World® Forums

How to insert a degree symbol '°' into table field ? ? ?

I’ve a query.I have Toad 9.5.0.31 for Oracle 10gon my system.Whenever I try to insert a degree symbol ‘°’ into any field.It isautomatically converted into a question mark ‘?’ symbol. I am not facing this problem with others system of my Team.

Here in the attachment there is value ‘?C’ but i want to insert ‘°C’ for tempreture.but after saving the value ,it converts back into ‘?C’
I am not able to find out such strange behavior. Is there anything related to GUI or some options??
Thanks in advance who so ever would give me favorable advice.

csdcsd.bmp

The special characters you can use are determined by what character set the database is using. You can check that with the following query:
SELECT * FROM NLS_DATABASE_PARAMETERS where parameter = ‘NLS_CHARACTERSET’;

The degree character is CHR(176) in some character sets, but it may be different in others. You need to check that and possibly use the CHR function to put the character in the database if you are pasting the degree character into Toad on your workstation and that is using a different character set such that the degree character would get translated into a value that the database’s character set doesn’t support.

Regardless, very doubtful it is a Toad Issue.

I have tried with the above written query , it gives me value ‘UTF8’.
But actually the problem is somewhat different , i want to ask whether there is any setting in Toad due to this happening.

We are migrating some data from xml files into database , everyone is using the same version of Toad for Oracle but still don’t know why when data loads in my database it converts degree symbol into a question mark.
i am unable to find out the setting or the problem.Help me out…!!

So are you saying others can see the degree symbol correctly coming out of the same database but you cannot? I’m no character set expert, nor do I have a UTF8 database to test with, but I would guess that maybe your PC can’t display the unicode characters. See if you can use the CHR function to at least verify that the correct unicode value for that character is in the database.

Morning all,

late to the party, as I’ve been on holiday, but:

So are you saying others can see the degree symbol correctly
coming out of the same database but you cannot?
Can you DESC the table and show the data type for the affected column please. If it is a VARCHAR2, CHAR or CLOB then the database default character set will be used. If it is NVARCHAR, NCHAR or NCLOB then the NLS_CHARACTERSET will be used.

Next up, SELECT column_name,DUMP(column_name, 16) FROM table WHERE something; will display the hex code of the column’s data. You should try to restrict this so that you get as few rows back as possible to reduce the hex you have to trawl through!

Finally, what FONT have you configured in the TOAD results grid/script output? If it is COURIER then it may not be able to display the degree symbol correctly. Try changing to VERDANA or COURIER NEW as they can/should be able to display these things correctly.

HTH

Cheers,
Norm. [TeamT]

Information in this message may be confidential and may be legally privileged. If you have received this message by mistake, please notify the sender immediately, delete it and do not copy it to anyone else.

We have checked this email and its attachments for viruses. But you should still check any attachment before opening it.
We may have to make this message and any reply to it public if asked to under the Freedom of Information Act, Data Protection Act or for litigation. Email messages and attachments sent to or from any Environment Agency address may also be accessed by someone other than the sender or recipient, for business purposes.

If we have sent you information and you wish to use it please read our terms and conditions which you can get by calling us on 08708 506 506. Find out more about the Environment Agency at www.environment-agency.gov.uk