Save UTF-8 without bom in teamcoding

Hi,
when executing sql files generated via teamcoding i always get the following error:

SP2-0734: unknown command beginning "SET DEF..." - rest of line ignored.

I have already learned in the forum that the likely proble is that the files are encoded utf-8 with bom, so i tried to fix it by switching in the editor to utf-8 without bom. This did nothing.

is there any other configuration for teamcoding to do?`

Thanks in advance

I am fairly certain that SQL*Plus can only take ANSI encoded files.

Have you tried Options -> Files -> General -> Default Encoding? (Note, if you change that, it will not modify files already in Team Coding..it would affect new files)

Hi,

thanks for your reply. i switched to uft-8 before because of problems with german specific characters. These result in an error when running them via sqlplus.

Ok i have now switched to UTF-8 deleted the files loaded them back in form toad:

The error is still the same:

For me, SQL*Plus only works with ANSI encoded file.

I get the same as you when I save as UTF-8. I get different (but also wrong) results when I use any of the other encodings. Can you specify a character set to use with ANSI so that German characters will work correctly?

Another possibility - you can use QSR instead of SQL*Plus and it will handle all of these encodings.