Toad World® Forums

How to search within a row

I use Toad for Oracle 12.10.0.30. I recall from a previous version I could go to any table, any row, type CTFL-F, and search for a column.

I'd go to that column IN THAT ROW.

Now, I go to that column in the TOP ROW.

Makes life a bit difficult.

Can I disable this feature ?

I just tried this in 12.1 and it worked for me. Here is what I did:

  1. Go to Schema Browser, Data Tab (or any grid)
  2. Find the row that you want
  3. Do CTRL+F
  4. The Grid Column/Data find dialog appears.
  5. Click "Find Column" if it is not already clicked
  6. Click over in the column listing and start typing the column name that you want to find.
  7. Click the column that you want in the find dialog.
  8. Click OK.
  9. The grid is now on the column you searched for, and in the same row.

John confirmed this is working for 12.1, although 12.10 was mentioned. However, I just confirmed that Find Column works as you describe for Toad versions 13.x.... so unless we changed something in 12.10.x specifically...(John D can confirm again) you may want to re-test... or send a quick clip to help us reproduce.

Oops I misread the version number. I'll try again in 12.10 tomorrow.

Gary did you mean that it's broken or working in 13.3?

Ah, thanks...meant to say that Toad is working successfully as John describes...I can't reproduce the issue.