Toad World® Forums

How to "set define '~'" in TOAD

I want to use another character than & to prefix my variables in scripts.

How can I change the & to ~ (in SQL-plus we use "set define '~'" )

With kind regards

Hey Rob, welcome to the Toad forums.

Haven't tested it yet, but would Toad's SQLPlus execution mode help here... e.g. if you're using these ~ -prefixed variables mostly in SQLPlus anyway?

Toad should follow the same "SET" command as SQL Plus.

Thx John,

When using F5 and run as script it works fine, but with F9 (or Formatter ctrl+shift+F) toad does not work as expected (with & it works better)

Oh, ok. We don't have a way to set that. I'll log it as an enhancement request.

1 Like

Great, Please keep me updated when it's solved :slight_smile:

By the way, this option may help you. Right-click in the editor to set it.