I want to NO INMEMORY phrase for Create Tablespace

I create DDL script for Oracle 19c(19.3.0) how run Database > Export > Generate Schema Script.
In create Tablespace, it included "NO INMEMORY".
I knew that INMEMORY feature of Oracle provided from 19.8.
So, it is not need to create NO INMEMORY phrase.
Even it can't reverse engineering from erwin Data Modeler 12.1 causes that phrase.

How can I set generate option to except NO INMEMORY phrase ?

Il-Soon, Im

You mean, like this?

Hello, Gray.
Thanks for the comment.
But I set as your comment like attached but "NO INMEMROY" script created.

Hello Il-Soon,

The option that Gary showed in his screen shot should prevent the IN MEMORY clause from appearing, but I see that it does not. This is a bug and I will fix it for version 17.0.

As a workaround, you can set the script compatibility option as shown. This will, of course, also hide any other clauses that are new to version 12 and newer.


Sorry for the inconvenience.


Hello, John.
Thanks for the update clearly.

I test as your guide and I checked it created as I want.
I understand it is a bug and it will be fix at version 17.
It would be great if you notice when will release that version.
Thanks a lot.

Best Regards,
Il-Soon, Im