Toad World® Forums

Import Data Wizard - use "Text" as default column type instead of "Varchar(n)" for Postgresql databases

I am using Toad Data Point to generate new tables from CSV files.

The target connection is a Postgresql 11 database.

When it detects alphanumeric columns, the Import Wizard is defaulting to a column type of "varchar(n)" where n is the estimated max text length.

In Postgresql, a Varchar is simply a Text column with a length constraint. It is often preferred to use the Text column type unless the db is being counted on to enforce data lengths.

Is it possible to configure Toad Data Point to instead suggest Postgresql column type of "Text" for all alphanumeric CSV columns instead of "Varchar(n)"?

The workaround is to manually edit each column type from "varchar(n)" to "Text", but I would prefer it to use "Text" automatically.

Have you tried simply typing in "TEXT" for each of the columns that you'd like to have this type for?
Worked for me. Not sure why "Text" is not included in the drop-down list of possible data types.

Yes, I am able to manually modify the column type to "Text".

My request is for it to automatically default to "Text" instead of "Varchar(n)" in the first place.

Is this possible to configure? Or would this require an enhancement?

Ah, yes, apologies for glossing over your last line, so you're already doing this. Appears, then, to be an enhancement request. Quest R&D team can pick the request from here, but probably better to enter it into the Idea Pond.

1 Like

Thanks, I've moved this to the Idea Pond and reworded my question into a request.