Toad World® Forums

Import of Excel file fails because of "#NAME" error


#1

When I try to import a excel file in Toad Data where a cell contains a formula and is by default changed to “#NAME” I get an error.

The error message is attached in this topic.

I am certain that the problem is the hashtag. Therefore, somehow I need to have that deleted automatically when importing the excel file. Otherwise, change the cell value for Toad Data Point to import this file.


#2

I recreated your issue, but have to ask: what happens if you respond to the message by clicking NO (i.e. not canceling the import)?

For me, TDP still does the import of the rows (into a new table), and in the place of #NAME?, the cell gets populated with “NAME”. Just curious if clicking NO to the message will get you at least part of the way where you want to be. You can likely go into the table and change the contents of the #NAME fields after importing.

Otherwise, this sounds like an enhancement request for our PM/Dev team to consider (e.g. what to do about #NAME?, #ERR, and other anomalies found in an Excel spreadsheet upon import.) An option to ignore? Treat as an empty field? Default number or literal?


#3

You could mark that column as excluded in the Import wizard. there is a page where you delete a column from the import list.
Or you might consider connecting to the excel file an generate a query that gives that column an alias and using that query result as your import. I have not tried this one to see if it works.


#4

When I click “no” to the message another error message pops up.
error%20message%20toad


#5

May we ask what is the use case for trying to import a spreadsheet with formula/syntax errors, then?