Toad World® Forums

Intermittent problem - cannot switch connections when describe window is open


Morning All,

I’m (still) on Toad, 64 bit on WIndows 7.

Very occasionally, about once or twice a week, possibly when my sessions have been open for a while, I notice that if I have the describe window open on one session then any attempt to switch to another session using the connection bar, appears to work, but I’m immediately sent back to the session that has the describe window open. The connection bar does show that I’m on the first session - that button is down.

I cannot reproduce this at will, so I’m happy for it to be put on the very back burner until I can, or at least, find some combination of events that causes it, but I thought I’d mention it.

Norm. [TeamT]


That sounds familiar, Norm. I found this in our bug tracking system. If this is it, it’s been fixed in 13.1. If this is not it, let me know.


  1. In Options, Check “Show only buttons for current connection on window bar”
  2. In Options, Check “all describes are contained in single tabbed window”
  3. Start Toad and open a describe dialog. On the describe toolbar, click the dropdown arrow on the last button and uncheck “Allow multiple connections”


  1. Start Toad.
  2. Open 2 connections.
  3. Open a Describe dialog and an Editor in each connection
  4. Maximize the Editor of Connection 2 in Toad.
  5. Click the connection button for toolbar 1. The active connection changes in Toad - toolbars are updated.
  6. Try to click the editor window button for connection 1.
    bug: Toad changes active connection back to connection 2.

workaround: either close describe windows, or
use the “Window” main menu item, or
un-maximize the editor and then click on the other one.


Hi John,

Sounds like it’s similar - I’ll see what I can reproduce tomorrow at work.

As ever,



Morning John,

My setup is exactly the same as described. So far so good. However, when I try to reproduce the bug as per the steps involved, I don’t see the bug happening I’m afraid - which is a good thing. I can swap between sessions happily, and get the correct editor with no problems.

I’ll keep an eye out for when it next happens to see if I can come up with a recipe to make it misbehave.

Norm. [TeamT]


darn, I was hoping that was it. OK, let me know…