Issue with Account Used for Script Execution

I am a total newbie, so maybe I just don't understand something. :blush:

We have a new installation of TIC 5.5. I've published an automation both using the default account and and later switched it to my personal account. When running the automation as the default account, it fails with an access to a path error. That makes perfect sense because the Local System account does not have access to a folder that is referenced in the automation.

However, when I change the credentials to use my Active Directory account, which does have the needed privileges, it also fails. The Exit Code is -151 and the log is completely empty, as if it couldn't even get started.

I would appreciate any hints on how to troubleshoot this issue.

In reading the Deployment Guide, I saw the following note.

Note: Beginning with Toad Intelligence Central 5.1.5 Toad would add the user account that executes automation scripts to a new OS (Windows server) group called TIC Automation. This new group’s permissions are similar to normal Users group with some additional permissions necessary to execute automation scripts. Toad Application Server (ToadBIAppServer), is the service that triggers execution of Toad Data Point Automation Scripts in Toad Intelligence Central, its default login is Local System account.

I do not see a Windows group called TIC Automation on the host server. I don't know if that may be part of the problem or not.


More info. This doesn't seem to be related to access to a network folder. I tried running an automation that does not access a network folder and it runs fine as the default user, but fails when run with my personal credentials.

This problem appears to have been related to the ability to Run as a batch job. In any case, problem solved.