Toad World® Forums

Run Automation script in differente computers

Hello,
I have created an automation scritp that needs to be run from different computers. All these computers have the TOAD For Data Analyst 2.7 installed and running in their C: drives, and have access to the required databases. However, when I try to run the automation script that was created in one computer, in another, it reports an error concerning the automation log:

“Automation Log. Disabling Loggind. Access to c:\Documents and Settings\user\ApplicationData\Quest Software\Toad for Data Analyst 2.7\Automation”

I guess that the logging tries to access to the path where the script was created, and since access between computers is restricted, the automation can’t be run.
Could someone tell me if it is possible to prevent the logging for the automatino process or if there is anything else I can do to avoid this problem?

Thank you very much for your help!

In the “activity properties” there is a logging section where you can set the logging level to none.

Dave,
Thanks for your answer, I was about to give up. Could you be a little more specific on where this logging section is? I can’t seem to find it. I am using the v2.7

Thanks a lot

Sorry, if you click on "Script Settings" the "activity properties" should appear. I highlighted the logging section in the attached picture.

Awesome!
It was under automation, I didn’t check that… my fault!
Hey! Thanks a lot! :slight_smile:

Also you should be able to reset the path of the logging file after you move the script to a different computer. Or build your scripts to always use a common log directory such as C:\temp. The default path is to use the users data directory, so it has a logid in the path name. That works great for single pc script running but does not port well. I’ll make a CR to look into this.

Debbie

This is now CR85905

Hey Debbie!
I didn’t think about that! Thanks for the tip! :slight_smile: