Toad World® Forums

Just curious


#1

We use Oracle Wallet for certain “secured” database instance and a central TNS file for everything else. Since implementing this using IFILEs in a TNS file I’ve noticed that TOAD can no longer list available instances, I have to type them in manually. IS there any way around this?

Chris Johnson

IT Systems Analyst

Distribution Logistics

615-855-4371


#2

When I add “ifile=c:\test.ora” to my tnsnames.ora, and then put a TNS entry in c:\test.ora, it shows up in the dropdown on the login screen.

What’s the difference between doing it this way and using Oracle Wallet?


#3

We may not be set up correctly, but it works other than this one quirk. I can connect to anything in the wallet or anything in the central TNSNAMES file, it just isn’t listing them in the connect dialog.

Here’s what we have:

TNS_ADMIN Environment variable that usually points to our central shared TNS file is changed to point to my wallet directory.

In the wallet directory I have:

The wallet files plus

SQLNET.ORA

IFILE = “//{{path to our shared TNSNAMES directory}}\sqlnet.ora”

IFILE = “C:\Oracle\wallet\sqlnet_wallet.ora”

SQLNET_WALLET.ORA

WALLET_LOCATION =

(SOURCE =

(METHOD = FILE)

(METHOD_DATA =

(DIRECTORY = “c:\oracle\wallet”)

)

)

SQLNET.WALLET_OVERRIDE = TRUE

SSL_CLIENT_AUTHENTICATION = FALSE

SSL_VERSION = 0

TNSNAMES.ORA

IFILE = “//{{path to our shared TNSNAMES directory}}\tnsnames.ora”

IFILE = “C:\Oracle\wallet\tnsnames_wallet.ora”

And TNSNAMES_WALLET.ORA which contains the standard TNSNAMES format for the connection strings we use with the wallet.

I didn’t set this up, a coworker did and he’s no longer with us, I just followed his documentation, so it may not be set up correctly, but as I said… it does work.

From: John Dorlon [mailto:bounce-jdorlon@toadworld.com]

Sent: Thursday, October 22, 2015 10:47 AM

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] Just curious

RE: Just curious

Reply by John Dorlon

When I add “ifile=c:\test.ora” to my tnsnames.ora, and then put a TNS entry in c:\test.ora, it shows up in the dropdown on the login screen.

What’s the difference between doing it this way and using Oracle Wallet?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.


#4

Morning All,

John’s reply about an IFILE command causing the included tnsnames

aliases to be included in the drop down was interesting, as I’ve never

seen it happen! Usually, when at work (in my last contract) I had a

local tnsnames with two IFILE directives, one to pull in the standard

tnsnames frile, and one to pull in my own, or test stuff. None appeared

in the drop down, only anything hard coded into the local tnsnames.ora.

I know that this was also the case quite recently for version 12 as I

used that to perform a technical review of Bert & Dan’s "Toad for Oracle

Unleashed" book that has recently hist the shops. So, I’ll need to go

off and play a bit to see if it all “just” works now.

Ok, in version 12.1.1.1, I am unable to see anything outside the

tnsnames.ora file for my default oracle home (the only home on my

laptop) but I can connect to any alias I have set up in the included IFILE.

Perhaps it is Chris’ version of Toad that is causing the entries in the

IFILE(s) not to be included in the drop down? Or John has a much more up

to date Toad than we have? Just a thought.

What I eventually did with my own system - back in my last contract -

was to take the various tnsnames files, and pass them through a

converter that I wrote (sadly, in Java!) which allows me to import the

connections into my connection grid as per the new session dialogue.

If anyone wants to play with this, it’s at

qdosmsq.dunbar-it.co.uk/…/.

If you wish, there’s also a tnsnames validator utility at

qdosmsq.dunbar-it.co.uk/…/

which carries out syntax and semantic validations on your tnsnames file(s).

These are both free, source is available, and might be useful, perhaps,

maybe!

HTH

Cheers,

Norm. [TeamT]


#5

Morning All,

John’s reply about an IFILE command causing the included tnsnames aliases to be included in the drop down was interesting, as I’ve never seen it happen! Usually, when at work (in my last contract) I had a local tnsnames with two IFILE directives, one to pull in the standard tnsnames frile, and one to pull in my own, or test stuff. None appeared in the drop down, only anything hard coded into the local tnsnames.ora.

I know that this was also the case quite recently for version 12 as I used that to perform a technical review of Bert & Dan’s “Toad for Oracle Unleashed” book that has recently hit the shops. So, I’ll need to go off and play a bit to see if it all “just” works now.

Ok, in version 12.1.1.1, I am unable to see anything outside the tnsnames.ora file for my default oracle home (the only home on my laptop) but I can connect to any alias I have set up in the included IFILE.

Perhaps it is Chris’ version of Toad that is causing the entries in the IFILE(s) not to be included in the drop down? Or John has a much more up to date Toad than we have? Just a thought.

What I eventually did with my own system - back in my last contract - was to take the various tnsnames files, and pass them through a converter that I wrote (sadly, in Java!) which allows me to import the connections into my connection grid as per the new session dialogue.

If anyone wants to play with this, it’s at qdosmsq.dunbar-it.co.uk/…/.

If you wish, there’s also a tnsnames validator utility at qdosmsq.dunbar-it.co.uk/…/ which carries out syntax and semantic validations on your tnsnames file(s).

These are both free, source is available, and might be useful, perhaps, maybe!

HTH


#6

Twice???


#7

In my test, I did not have double-quotes around the path.

So, this worked fine:

ifile=c:\test1\file1.ora

ifile=c:\test2\file2.ora

but when I added the quotes, like this, it stopped working. I’ll fix that.

ifile=“c:\test1\file1.ora”

ifile=“c:\test2\file2.ora”

Norm, I tested all the way back to 11.6 and it worked without the quotes.


#8

That was the trick. Removed the double quotes and now it works. I checked connections both in the wallet and external and all seems to be working correctly now.

Thanks John!

From: John Dorlon [mailto:bounce-jdorlon@toadworld.com]

Sent: Monday, October 26, 2015 8:10 AM

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] Just curious

RE: Just curious

Reply by John Dorlon

In my test, I did not have double-quotes around the path.

So, this worked fine:

ifile=c:\test1\file1.ora

ifile=c:\test2\file2.ora

but when I added the quotes, like this, it stopped working. I’ll fix that.

ifile=“c:\test1\file1.ora”

ifile=“c:\test2\file2.ora”

Norm, I tested all the way back to 11.6 and it worked without the quotes.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.


#9

Hi John,

good news indeed, thanks. As far as I remember from the Oracle docs, there should be double quotes around the filenames. However, a quick check shows that this is not/no longer the case - at least from 10g onwards. Mind you IFILE is only documented as an init.ora parameter!

I can confirm that removing the double quotes does cause the aliases to appear in the drop down list. This is true for nested IFILEs, at least to two levels.

Thanks John. (Now I need to go fix my tnsnames checker to cope with and without double quotes!)

Cheers,

Norm.