Toad World® Forums

tnsnames_ifile problem

Hi,
12.10.0.23 x64.
Open Toad.
Add entry in tnsnames_ifile.
Refresh login screen, entry exists in combo Toad list but cannot login (TNS does not exist error).
Restart Toad-not help.

Add in tnasnames.ora-work that entry.

Your Oracle client makes the connection, not Toad. The bug/problem is in the Oracle client. There is something it doesn’t like about your tnsnames.ora file or the include file.

If there is any problem in Toad here, it’s that we are not also identifying the problem.

If I may blow my own trumpet here …

If you have problems in a Tnsnames.ora file, or an included I file, then things go a little funny to say the least. It’s definitely not as bad as it used to be though.

I wrote a Tnsnames.ora validator a while back, to the 11gr2 specifications. Details are on my blog, and also on Toad World. http://qdosmsq.dunbar-it.co.uk/blog/2014/12/tnsnames-checker-utility/

John, I presume you can delete this post if it is considered unsuitable/spam/etc.

Cheers,

Norm [ TeamT ]

Sent from my Android device with K-9 Mail. Please excuse my brevity.

Norm, I have never deleted any of your posts and I’m not about to start now!

I knew that, but some mailing lists, fora (forums?) don’t like people promoting their own stuff.

I added that option, just in case.

Cheers,

Norm.

On 2 September 2016 14:15:38 BST, John Dorlon bounce-jdorlon@toadworld.com wrote:

RE: tnsnames_ifile problem

Reply by John Dorlon
Norm, I have never deleted any of your posts and I’m not about to start now!

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or Unsubscribe from Toad for Oracle - Beta Forum notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag this post as spam/abuse.

Sent from my Android device with K-9 Mail. Please excuse my brevity.

I am able to reproduce the bug.

  • Open Toad and connect to some existing connenction
  • Open ifile and add new entry (check in command prompt-it is valid!)
  • Open new Toad conenction dialog, TNS entry is shown, choose it, but when you choose to connect button, mentioned error is shown.
  • Close Toad
  • Restart it-the same entry works as hell.
    Obviously some parts in connection dialog are not refreshed properly.

This is a problem in last official Toad 12.7 (not only beta) as mentioned here (tested as well).
:slight_smile:

This sounds familiar. John was working on this or a very similar problem for me recently. If you add an entry to an Ifile, then Toad won’t see it unless you either restart Toad, or, use the Tnsnames.ora editor feature on the New Session dialogue, to edit and save the existing Tnsnames.ora file. That will cause Toad to refresh that file plus any others that are ifiled by it.

In 12.7 you can press F5 on the dialogue to reread the Tnsnames.ora file,prior to that, you need to do as above.

Details here www.toadworld.com/…/31379 if you are interested. I’m on 12.6 so I’m not able to use F5.

HTH

Cheers,

Norm. [ TeamT ]

thx Norm…seems this is an old story.