Killing SQL-Statement does not work

This is a problem since TOAD 16, I guess.
When I try to cancel the execution of a SQL-Statement (even after 2 seconds of starting the execution), the small window messaging 'Canceling the statement' stays forever and does not cancel the execution.
In a second instance of TOAD I can see the statement is still active and executing.
When I kill the session from there, I got the error
"Access violation at address 00007FFCD095D4BF in module 'oraociei.dll'. Write of address 0000000000000020"
in BOTH Toad sessions, so the only solution then is to close both running instances of TOAD and start completely over again.
Has anyone observed anything like this?

I just tried to cancel a slow-running SELECT statement from Toad 16.3 and the SQL was cancelled after about 1 second.

Both of these cancelled just fine for me.

select *
from dba_objects, dba_tables
order by 1
select delay(10)
from dual;

Delay is a function that I use to make SQL run slowly. It looks like this:

CREATE OR REPLACE function delay(value number) return number
  return value;

Can you post the SQL that you tried to cancel?