Toad World® Forums

Local Storage Connection error please help!

IUsing Toad 3.6

Automation Script

Hi I have an automation script that runs weekly that quit running today. The error says "unable to connect to any of the specified Local Storage hosts." Above this error is " There was a connect error. Check that the username and password are correct, that you have registered this user using the registration tab, and that the registered user has not been disabled." I have no idea what this means. I have not changed passwords. I also tried to connect to the local host manually and I get the same error. I tried to create a new connection and can't find "Local Storage" as an option. Attache is a screen print of the error message.

You have to reset the local storage. To do that you should rename the local storage data folder. You will find the folder path in the Tools|Options as show here



I tried this and it did not work. Gerrr. I tried to uninstall Toad to see if that would help and no. Toad would not let go of this path. Any idea???

Reinstalling TDP would not help if you don’t rename the directory.

Have you renamed the directory? The default directory path is

C:\Users\YOUR_LOGIN_NAME\AppData\Local\Quest Software\Toad Data Point Hub Data

You have to rename the directory when Toad is not running.



Yes I did rename the directory. I had moved it to one of our network drives some time ago. I wish it could be so easy. I am now trying reseting all my defaults. Fingers crossed…

Resetting my defaults did not help. Above is the new path I entered and I clicked yes to the box that said I had to restart Toad. I restarted toad and when I went to try to connect it came up with the old default path. The network path worked fine until two weeks ago when my script started failing saying it could not connect. I am at a loss.

I’ve also had this problem - still do in all honesty!!

I found a manual workaround in a post from Debbie in Feb 2013

  1. Let’s try to do the move manually.

a) First copy all of the files from the old location to the new location.

b) Rename the old dir.

c) Open up settings.xml and set the path of dataHubDataFolder

D:\Local Storage DataHub

d) restart app and see if you see your local storage files and if the option window reflects the correct path.

Is the drive you use mapped to a network drive? you need to stay local with the directory. Please try a local drive to see if it works or not.

I talked with someone else and we need to try starting the embedded database in a command line prompt. This command varies per installation. Can you open a support ticket? That might be easier. If not, go to your shortcut and add " /log=all" on the app path. Start TDP and try to connect to local storage. Then post the Toad.log file that is in your app data dir. It will contain the command line I need. I would need to grab it for you. Then we can execute in cmd window and get more info.