Toad World® Forums

Local storage connection failing

I'm having a problem connecting to my "Local Storage Connection" . It was working at one point and I'm not quite sure when it stopped, but now when I try to connect it gives the error below.

I tried adjusting some settings, rebooting several times but cannot get it to work.

I have colleagues who share this issue, and some who do not. I have exported the XML connection details for a working and non working connection for your review.

Broken connection:

working connection:

I saw one difference (port=65431) but I am not sure how to make that change on the broken connection.

Thanks!
Dan

The only thing I have gotten to work is to go into the Toad Data Point settings and change the directory for my Local Storage. Once I did that, closed the program, reopened and it worked for me. This is one of the most common errors I experience in using TDP so you will probably see it again.

I just tried this, unfortunately it did not solve the problem for me.

Same thing started happening to me yesterday. I also tried to change where storage is kept, but I am still unable to connect. Something really seems to have turned off the local storage feature?

There are numerous articles on the Forum if you search Google for the error message and Toad Data Point. One fix is the renaming of the directory. Others recommend renaming some directories outside of Toad. I would suggest looking those up and trying some of the suggested resolutions. In most of my cases just renaming the folder in Toad for Local Storage works, but I have had to go beyond that before.

Best of luck

Thanks for the info rvaldez3! The thing is, I have been using this product for over 10 years, something happened yesterday that is very different and now the local storage feature is disabled. It might be on my Company's side of the firewall, but something recently broke this (both in 5.1 and 5.0 TDP), maybe it was a WINDOWS update, I just do not know.

I have tried renaming folders, and anything else I can find on google, and it is not fixing it for me. (maybe I'm just not searching the right way)

I also have coworkers who have only just installed TOAD Data point recently , within the last few weeks, and this is their first time trying to connect to local storage and it is failing for them as well. Some other new users it works. So whatever is wrong it seems somewhat random and is not caused by the user.

FYI I am using Toad Data Point 5.1.0.142 (64 bit).

Hi dschmitt3,
TDP local storage is just a MySQL db, so it cannot be connected maybe caused by some local env issue , for example secure application, local policy , etc.

Can you send me the error log for this?
1)You can try one more time that connect to local storage, it should be failed in your env.
2)Send the support bundle to us Help-> SupportBundle, by default, after support generate successfully, TDP will open an email and attach the support bundle, you just change the email address from support@quest.com to vincent.hu@quest.com, then I will check the log first .

Vincent