Toad World® Forums

Local Storage Location Change


#1

I am trying to change the default location of Local Storage and keep getting the following error:

You must restart the Local Storage connection to make this change.

What needs to be done to update the default location?


#2

Just do what it asks for: go to Connection Manager and reconnect to Local Storage if you were connected to it or just connect if not. Actual Local Storage data relocation will be accomplished during first connection after location change. You might see an error message saying “table ‘definitiontable’ already exists” and this is a bug that is to be tracking in CR106482, but closing this dialog and reconnecting to Local Storage one more time actually does the job.

Igor.


#3

I’ve done this multiple times and nothing happens:

  1. Update the path
  2. Click Apply
  3. Ok the popup (Can’t select the connection manager with the popup active)
  4. Right Click “Local Storage Connection” and select Reconnect/Connect (with the options dialog still open)

I am trying to move it to a different hard drive due to space limitations on my C:. Is this the problem?


#4

It shouldn’t be a problem. Can you please download the latest 1089 beta and see if you can reproduce the issue there? I tried multiple scenarios including moving Local Storage to external drive - working fine.

Thanks,

Igor.


#5

This is odd. I tried it once and it didn’t seem to work. Then I tried again and it worked fine. Try the beta as Igor said and let us know how it goes.

Is the drive local? Or network location?

Debbie


#6

Igor,
I installed the 3.3 Beta and it still doesn’t work. I get the pop up hit ok and connect/reconnect to local storage and nothing happens. Just connects to the local storage but never moves the data or saves the path.

Debbie,
It is a local drive, just a second hard drive.

Instead of using the options dialog can I manually update a settings file or something?


#7

By the way, I also tried another location on my C: and it still didn’t work


#8

We can try two things.

  1. Add “/log=all” to your shortcut and run program and try to change local storage path. This will product a file that will have some logging in it.

Like this.

“C:\Program Files (x86)\Quest Software\Toad Data Point Beta 3.2\toad.exe” /log=all

After you shut down the app, go to app dir and attach Toad.log to this post.

  1. Let’s try to do the move manually.

a) First copy all of the files from the old location to the new location.
b) Rename the old dir.
c) Open up settings.xml and set the path of dataHubDataFolder

D:\Local Storage DataHub
d) restart app and see if you see your local storage files and if the option window reflects the correct path.

Debbie


#9

Debbie,

  1. I attached the log file to this post as requested
  2. Manually updating the settings.xml file worked. I can connect to the local storage and the path accurately appears in the options dialog box.

Thank you for all the help
Toad.log (213 KB)


#10

I am glad the manual method worked. I couldn’t find anything useful in the file to explain what happened. So for now let’s stick with the manual method.

Debbie