Toad World® Forums

Loosing color and formatting when copying queries from TOAD to Word or Outlook


#1

Hi

This may be TOAD-related - but might as well be something else:

I recently had to set up a new laptop with TOAD - this time on Windows 10.

Now I realise I can not copy a formatted (and colored) SQL-statement from the TOAD editor into a word-document or an email (set up with HTML format). When pasting it from clipboard - it just comes out as plain text.

I have a collegue with the same setup Windows 10 and Toad 12.9 64 bit. She does not have this problem. And I did not have it on my previous laptop running Windows 8.1 Update and TOAD 12.9

I have now upgraded to TOAD 12.10 - but it did not help.

When copying from other sources (like a web-page) - I do not loose color or format.

I did find some very old discussions on the net - on the same issue - but from back in 2005-2007. They said it had something to do with Skype - but that is not my case.

Anyone got i solution? It is very annoying!

Geir K. Edland


#2

Geir,

Try Options -> Editor -> Behavior -> Copy text in rich text format.


#3

If you will go to “Options->Editor->Behavior” and check “Copy text in rich text format”… that should fix your issue.

David

From: geir.k.edland [mailto:bounce-geirkedland@toadworld.com]

Sent: Thursday, December 08, 2016 6:54 AM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] Loosing color and formatting when copying queries from TOAD to Word or Outlook

EXTERNAL EMAIL

Loosing color and formatting when copying queries from TOAD to Word or Outlook

Thread created by geir.k.edland

Hi

This may be TOAD-related - but might as well be something else:

I recently had to set up a new laptop with TOAD - this time on Windows 10.

Now I realise I can not copy a formatted (and colored) SQL-statement from the TOAD editor into a word-document or an email (set up with HTML format). When pasting it from clipboard - it just comes out as plain text.

I have a collegue with the same setup Windows 10 and Toad 12.9 64 bit. She does not have this problem. And I did not have it on my previous laptop running Windows 8.1 Update and TOAD 12.9

I have now upgraded to TOAD 12.10 - but it did not help.

When copying from other sources (like a web-page) - I do not loose color or format.

I did find some very old discussions on the net - on the same issue - but from back in 2005-2007. They said it had something to do with Skype - but that is not my case.

Anyone got i solution? It is very annoying!

Geir K. Edland

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle Forum
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


***** This email is from an external sender outside of the CenterPoint Energy network. Be cautious about clicking links or opening attachments from unknown sources. *****



#4

Thanks! I thought I had checked all options - but obviously not! Good til be “back on track”!


#5

I had the option “Copy text in rich text format” checked, but was still plagued by not getting the rich text copied into either a new Outlook email message or a new Word document. Apparently in Office, I had previously set a default paste option as Text Only. So, the answer is to click on the little Paste Options button in the target document (e.g. e-mail or Word document) and make sure to select “Keep Source Formatting”.


#6

Get it via the defult option after setting the code or px.

With Regards,
Xovo Larjem https://8ballpool.onl/
https://googlehangouts.ooo/