Toad World® Forums

Mast-detail browser window sizing

The window for the first table in the master-detail browser chain does not size correctly–it seems to default to the number of rows - 1 starting with v12, so that if you filter the first table for one row, the window sizes itself so that no rows are showing. If you filter for two rows, the window sizes to show only one row. I use the browser a lot, and this is quite annoying. If there is a workaround other than manually resizing the window, I’d love to hear about it

The idea was to make the window just big enough to show however many rows there were, not cut off the last one. For me, it seems to work correctly on 12.1, but I can reproduce the problem on 12.5 and 12.6. When you say V12, exactly which version are you referring to?

One workaround is to check the “Single grid mode” checkbox. Then you can move from one grid to the other by clicking on the one you want in the navigator.

Fixed for next beta. The horizontal was part of the problem. So hide it if you can. Maximize Toad to hopefully eliminate the need for the grid’s horizontal scrollbar, and if the grid’s navigator is visible, hide it. (rt-click in grid -> appearance -> toggle navigator)