Toad World® Forums

Multi-line tab/indent doesn't work in smart tab mode

Hi,

I’m using Toad 12.7.0.49, 32bit.

If I set the tab mode to spaces, I can highlight a block of text and hit the tab button and it will indent the whole block one space. Multiple tabs make it indent by the same number of spaces (and the same applies for shift+tab).

However, if I change the tab mode to smart, highlight a block of text and then hit tab, all that happens is the highlighting is removed and the text to the right of the caret jumps to the next tab stop as if I hadn’t highlighted the block at all. The same thing occurs if I use the indent/unindent buttons on the toolbar.

Any chance that could be fixed, please?

If I set the tab mode to spaces, I can highlight a block of text and hit the tab button and it will indent the whole block one space. Multiple tabs make it indent by the same number of spaces (and the same applies for shift+tab).

I’m not quite following you here. Can you send me your user files folder to michael.staszewskiquest.com? I did see some bugs comparing 12.6 to beta that are fixed for the next beta, but I don’t think they are what you’re reporting. If you send me some screenshots of your before/after tab that would help too. Thanks.

I have tab mode set to space, tab stop at 4. I select a block of text…

After Tab or clicking Indent I get this…

However, if I change the tab mode to smart, highlight a block of text and then hit tab, all that happens is…

This should be fixed in next beta (.50). Check it out and let me know if there’s still a problem there.

Thanks,
Michael

On 03/05/2015 10:40 AM, Boneist wrote:

Multi-line tab/indent doesn’t work in smart tab mode

Thread created by Boneist
Hi,

I’m using Toad 12.7.0.49, 32bit.

If I set the tab mode to spaces, I can highlight a block of text and hit the tab button and it will indent the whole block one space. Multiple tabs make it indent by the same number of spaces (and the same applies for shift+tab).

However, if I change the tab mode to smart, highlight a block of text and then hit tab, all that happens is the highlighting is removed and the text to the right of the caret jumps to the next tab stop as if I hadn’t highlighted the block at all. The same thing occurs if I use the indent/unindent buttons on the toolbar.

Any chance that could be fixed, please?

To reply, please reply-all to this email.

Stop receiving emails on this subject.
Or Unsubscribe from Toad for Oracle - Beta notifications altogether.
Toad for Oracle - Beta Discussion Forum

Flag this post as spam/abuse.

Sorry, the first paragraph was just me attempting to explain that multi-line tabbing works as I expect (I have it set to 1 space) when the tab mode is set to spaces, before then going on to say that it’s broken when I switch to smart tab mode.

I’ll recheck it when the next beta is available *{:slight_smile:

I can confirm that the indenting now works correctly in the smart tab mode. Thanks!