Toad World® Forums

Tab key indentation on multiple lines inserting spaces instead of tabs


#1

My settings have been set to use tabs and not spaces.

When I have my cursor at the start of a line and I press the tab key a few times to indent the line as required, the editor inserts several tab characters in front on the text as expected. But when I select more than one line and similarly press the tab key to indent multiple lines altogether, then the editor inserts spaces in front of these lines and NOT tabs.

Is there a way to fix this so that the tab key ALWAYS inserts tabs and not spaces regardless of how many lines I’m working with at once?

Thanks!


#2

ALWAYS inserts tabs and not spaces
View|Toad options:

Hope this helps.


#3

This is reproducible in current build. I’ll take a look.

On 04/07/2014 10:18 PM, poolsandra wrote:

Tab key indentation on multiple lines inserting spaces instead of tabs

Thread created by poolsandra
My settings have been set to use tabs and not spaces.

When I have my cursor at the start of a line and I press the tab key a few times to indent the line as required, the editor inserts several tab characters in front on the text as expected. But when I select more than one line
and similarly press the tab key to indent multiple lines altogether, then the editor inserts spaces in front of these lines and NOT tabs.

Is there a way to fix this so that the tab key ALWAYS inserts tabs and not spaces regardless of how many lines I’m working with at once?

Thanks!

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#4

You want to check the “Optimal fill” option in View|Options|Editor|Behavior. That gives the behavior you’re after.

On 04/07/2014 10:18 PM, poolsandra wrote:

Tab key indentation on multiple lines inserting spaces instead of tabs

Thread created by poolsandra
My settings have been set to use tabs and not spaces.

When I have my cursor at the start of a line and I press the tab key a few times to indent the line as required, the editor inserts several tab characters in front on the text as expected. But when I select more than one line
and similarly press the tab key to indent multiple lines altogether, then the editor inserts spaces in front of these lines and NOT tabs.

Is there a way to fix this so that the tab key ALWAYS inserts tabs and not spaces regardless of how many lines I’m working with at once?

Thanks!

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#5

Thanks Michael! OPTIMAL FILL is exactly what I was missing.