Toad World® Forums

New Toad is already expired?


#1

Hello all,

I’m sorry if this is in the wrong spot but I tried to download and install the newest version (12.5) on a PC and the installation goes well; however, when I launch the program, it says that “This version of Toad for Oracle has expired. You must download a new version before proceeding.”

Is there something I can do to get it to work? I mean, downloading it today and installing it, I wouldn’t think it expires after a few minutes. :expressionless:


#2

I assume you’re talking about Freeware. Uninstall, clear your internet cache, download again, and install. The Freeware we uploaded Monday expires July 2015

From: childfund_toad [mailto:bounce-childfund_toad@toadworld.com]

Sent: Wednesday, July 02, 2014 10:55 AM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] New Toad is already expired?

New Toad is already expired?

Thread created by childfund_toad

Hello all,

I’m sorry if this is in the wrong spot but I tried to download and install the newest version (12.5) on a PC and the installation goes well; however, when I launch the program, it says that
“This version of Toad for Oracle has expired. You must download a new version before proceeding.”

Is there something I can do to get it to work? I mean, downloading it today and installing it, I wouldn’t think it expires after a few minutes. :expressionless:

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#3

Yes, my apologies, I was talking about the Freeware.

I’ll try that and let you know. Thanks for the quick reply! :slight_smile:


#4

Hello,

Okay, so I just did what you suggested and that does work (it says it expires July 2015). However, now getting an error message that says there is no error(s) from what I can tell. Thoughts?

5700.toad.png


#5

Am I correct in assuming that the East Asian text is incorrect? That text comes from the exception tossed by Oracle so unless it’s being mangled after Toad receives it then your client is configured to show error messages in that language. If you have it configured that way intentionally then please translate it for us. Thanks.


#6

I’m not sure why it’s showing in Chinese (as Google translate thinks it’s that at least heh).

Where should I look specifically to do the “errors as english” option?


#7

You’ll need to Google that. I did and it looks like there are a few steps perhaps. Can you make that connection in SQL*Plus? If not what error message does it show and is the message in the language you expect?

On 07/02/2014 12:08 PM, childfund_toad wrote:

RE: New Toad is already expired?

Reply by childfund_toad
I’m not sure why it’s showing in Chinese (as Google translate thinks it’s that at least heh).

Where should I look specifically to do the “errors as english” option?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#8

Hmm, well the quick research that I did found this:

www.dbasupport.com/…/showthread.php

Went to: HKEY_LOCAL_MACHINE\SOFTWARE\Oracle\HOME0 and changed NLS_LANG from NA to AMERICAN_AMERICA.CHARACTERSET but that didn’t help. Changed it back to NA as a precaution.

I’m not a DBA or anything (just desktop support trying to get it to work) so no idea here.

I installed the 12.5 freeware on our DBA’s PC and everything works fine, just not on the person that had the initial request. :frowning:


#9

Hmm, well, searched again and found this thread:

www.toadworld.com/…/10089.aspx

steps "1. Start a DOS session. Type set nls_lang and press return. If you get

“Environment variable nls_lang not defined” go to step 2. Otherwise, go

to step 3.

  1. Start->run. Type regedit and click OK.

Navigate to HKLM/software/oracle/HOMEn. (n is the digit at the end of

the Oracle Home you are using. If you have more than one installed. Open

each one till you find the setting for ORACLE_HOME that matches the one

you use in Toad.)

Once in the correct HOMEn, look for NLS_LANG on the right side. There

should be a value in it. If so, go to step 3. Otherwise, I would say

that your client install is not correct. "

I ran the “set nls_lang” command in the DOS prompt on the person’s PC that isn’t working and get the “not defined” message. Made sure all the HOMEn folders have the same NLS_LANG that the working person’s PC but still no-go.

I run the “set nls_lang” command on the working person’s PC and still get the “not defined” message. :frowning:

Curious, is there a minimum Oracle version that 12.5 supports? Thinking about it, the people that are receiving the error message all have Oracle version 8i whereas the person who has Toad working is, I think, Oracle version 11 (or 10 at the oldest since he has Win 7 64bit and not 32 bit like the others).


#10

Review the InstallationGuide.pdf in the <install_path>\Docs folder. Minimum client for 12.5 is 9.2.0.8.

On 07/02/2014 03:15 PM, childfund_toad wrote:

RE: New Toad is already expired?

Reply by childfund_toad
Hmm, well, searched again and found this thread:

www.toadworld.com/…/10089.aspx

steps "1. Start a DOS session. Type set nls_lang and press return. If you get

“Environment variable nls_lang not defined” go to step 2. Otherwise, go

to step 3.

  1. Start->run. Type regedit and click OK.

Navigate to HKLM/software/oracle/HOMEn. (n is the digit at the end of

the Oracle Home you are using. If you have more than one installed. Open

each one till you find the setting for ORACLE_HOME that matches the one

you use in Toad.)

Once in the correct HOMEn, look for NLS_LANG on the right side. There

should be a value in it. If so, go to step 3. Otherwise, I would say

that your client install is not correct. "

I ran the “set nls_lang” command in the DOS prompt on the person’s PC that isn’t working and get the “not defined” message. Made sure all the HOMEn folders have the same NLS_LANG that the working person’s PC but still no-go.

I run the “set nls_lang” command on the working person’s PC and still get the “not defined” message. :frowning:

Curious, is there a minimum Oracle version that 12.5 supports? Thinking about it, the people that are receiving the error message all have Oracle version 8i whereas the person who has Toad working is, I think, Oracle version 11 (or 10 at the oldest since
he has Win 7 64bit and not 32 bit like the others).

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#11

For NLS_LANG help I suggest visiting the
NLS_LANG FAQ
on Oracle’s site. They have a
handy page
that lists commonly used settings. If you’re in the US you probably want to use AMERICAN_AMERICA.WE8MSWIN1252. You can set this in your registry or as an environment variable. I create a system environment variable named NLS_LANG and set it to
AMERICAN_AMERICA.WE8MSWIN1252 so that all of my homes use this same value.

Michael

On 07/02/2014 03:15 PM, childfund_toad wrote:

RE: New Toad is already expired?

Reply by childfund_toad
Hmm, well, searched again and found this thread:

www.toadworld.com/…/10089.aspx

steps "1. Start a DOS session. Type set nls_lang and press return. If you get

“Environment variable nls_lang not defined” go to step 2. Otherwise, go

to step 3.

  1. Start->run. Type regedit and click OK.

Navigate to HKLM/software/oracle/HOMEn. (n is the digit at the end of

the Oracle Home you are using. If you have more than one installed. Open

each one till you find the setting for ORACLE_HOME that matches the one

you use in Toad.)

Once in the correct HOMEn, look for NLS_LANG on the right side. There

should be a value in it. If so, go to step 3. Otherwise, I would say

that your client install is not correct. "

I ran the “set nls_lang” command in the DOS prompt on the person’s PC that isn’t working and get the “not defined” message. Made sure all the HOMEn folders have the same NLS_LANG that the working person’s PC but still no-go.

I run the “set nls_lang” command on the working person’s PC and still get the “not defined” message. :frowning:

Curious, is there a minimum Oracle version that 12.5 supports? Thinking about it, the people that are receiving the error message all have Oracle version 8i whereas the person who has Toad working is, I think, Oracle version 11 (or 10 at the oldest since
he has Win 7 64bit and not 32 bit like the others).

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#12

Thanks much for the min. reqs as well as the links and info for the nls_lang. :slight_smile:


#13

Well now that you’re likely an expert on NLS_LANG configuration we’ve had a second report and it’s an issue in the third party component used for connectivity and data access. It’s fixed in their current version which is already in use by Toad 12.6 beta. I’d still ditch the old client or install a second, newer one for Toad to use, but I don’t know for certain if that will fix the issue. I couldn’t reproduce it with an 11g client.


#14

Haha, yes, I’m an expert now! :smiley:

I have to schedule a time with a user to upgrade their Oracle to version 9 (forgot specific version that we usually use in 9 here) and see if that works or not.

Thanks again for the help.


#15

Fyi - oracle currently only supports use of 11g and 12c. In fact only two versions you can download anymore unless you buy extended support which allows 10g support, but not 9i.