No more highlight other instances of selected text in editor

I just upgraded to yesterday and almost immediately notice that when I select a variable name (or any text) other instances of that text in the current editor window do not highlight like they did in 6.7. Is this an option that must be turned on? If so, where is the setting? I’ve looked and looked, searched and searched, but found none.


I had this same problem when upgrading to 6.9 and it’s rather annoying. It seems the default behavior for 6.8 in the Results windows and Data view is to edit, when IMO it should be select/highlight.

To fix this, go to Tools > Options > Environment > Grid > Uncheck “Edit cell on single-click”. I hope that addresses your issue.


Thanks for the help. However, that didn’t fix it. Even with that unchecked (it was checked before) and restarting TFSS, if I highlight text in an editor that appears multiple times, the additional occurrences do not highlight.



Ah, I totally misunderstood. Strangely the multiple instance highlighting works on my copy. I am running Toad for SQL Server (64 bit) so perhaps it’s a version difference. I couldn’t find any options to turn it on or off. Sorry I couldn’t help.

I would love it if someone from Quest would just let me know if this is a bug or if i’ve messed up a setting. Every time I notice it i go looking for a setting that I may have missed.

A little communication would go a long way.




Missing of highlighing option is very annoying. Is there a workaround?

That was strange !!!

Did you mean highlight disappear when you select any text or variable?

Have you try to reset user profile or setting in Toad?


I uninstalled Toad and cleaned all settings directories. After clean re-installation, there is no change. I am using version (x64)


I’m having the same issue with version
Waiting for a solution from Toad

How to set NULL value via Grid Edit ?


This functional was disabled during performance optimization.
Now we add option for it. Check latest beta

1 Like