Toad World® Forums

Overly intrusive Toad Insight Droplist

Hi

Mostly I love Toad Insight and have it turned on with all options and the pop-up delay set to the lowest allowed. There are a couple of issues though that make it get in the way sometimes.

1 - The order of the suggestions causes it to pick the wrong option when I just try to type.

For example, If I type “select * from table where col1 in (select …);” then when I start typing “in” the list pops up, but it automatically puts the suggestion of INTERSECT above IN so that if I type “in” and hit the space bar, it inserts the word INTERSECT.

likewise, typing “select” will tend to make it auto-select a table we have called selection_types.

This could be easily fixed by changing the order of the suggestions so that it is alphabetical order, or in length order - or just if what we have typed so far is a valid suggestion, automatically go with that.

2 - If the list is slow to pop up (presumably because it is querying the database) then TOAD freezes and by the time it appears it will often leave out a lot of what I have typed - or automatically made incorrect selections from the list.

Thanks

Dan

#1 In the current build “IN” is surprisingly missing from the list. I’ve sent the parser team an email about this. The list is ordered so that the most likely candidates appear at the top. In some cases there could be several candidates that are just as likely
to appear in the SQL at that point so the ordering won’t work for all. In your example I think the best solution would be to see that IN is also in the list and to use it instead of INTERSECT, but with IN not appearing at all this is impossible at this point.
In the meantime you can disable expected tokens from the pick list as a workaround.

#2 What version of Toad are you on?

Michael

On 08/05/2014 07:17 AM, DanCJ wrote:

Overly intrusive Toad Insight Droplist

Thread created by DanCJ
Hi

Mostly I love Toad Insight and have it turned on with all options and the pop-up delay set to the lowest allowed. There are a couple of issues though that make it get in the way sometimes.

1 - The order of the suggestions causes it to pick the wrong option when I just try to type.

For example, If I type “select * from table where col1 in (select …);” then when I start typing “in” the list pops up, but it automatically puts the suggestion of INTERSECT above IN so that if I type “in” and hit the space bar, it inserts the word INTERSECT.

likewise, typing “select” will tend to make it auto-select a table we have called selection_types.

This could be easily fixed by changing the order of the suggestions so that it is alphabetical order, or in length order - or just if what we have typed so far is a valid suggestion, automatically go with that.

2 - If the list is slow to pop up (presumably because it is querying the database) then TOAD freezes and by the time it appears it will often leave out a lot of what I have typed - or automatically made incorrect selections from the list.

Thanks

Dan

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

I am getting IN in my list. The moment I type “i” the top three entries are INTERSECT, IN and IS in that order - but it chooses INTERSECT.

I might disable expected tokens, but I want to try to persevere for now to see if I can get used to it.

I am on TOAD 12.5.1.1.

Thanks

#1 Interesting. On the same version with a query like the one you posted here’s what I see.

#2 Ok, I see what you mean now. Toad does all querying in a background thread so that you can cancel it with the escape key. Toad is not actually frozen although typing is blocked while we are populating the list. In the past typing was also blocked although it seems keystrokes were buffered and no characters were lost. They just appeared after the list was available. It’s very late in our 12.6 release cycle so I’m hesitant to change the behavior right now, but I’ve logged an issue to revisit this. It should buffer your keystrokes.

Michael

Looks like the screenshot didn't make it last post. Trying again.

Thanks.

Just for reference, here’s a screenshot of what I get:

example.png

Actually, thinking about it, maybe the best fix is to provide an option where hitting the space bar doesn’t select an item from the list. That way while I am typing, if I ignore the list it does no harm, but if I want it I can hit enter to choose an item.

#2 is fixed for 12.7. The fix will be available in the next beta (12.7.0.52).

Excellent - Thanks a lot!