Toad World® Forums

"Please enter password" error prompt when trying to import an excel document

Hello,

I'm running into an issue while working in Toad Data Point 5.0.7.106 (32 bit)

I have an automation script created and when I encounter the Import Wizard step it fails when I try to import large excel files (I've asked the other members on my team if they could try running this script and they all run into the same error as well). This import step is just trying to import an excel .xlsx file into a database and where I'm running into an issue is that a box will pop up in Toad to prompt me to enter a password with the text of this box reading "Please enter password". The issue is that this excel file is not password protected. I can open the excel file just fine it does not require a password and it's not in read only when opened this is an excel document that I have extracted and saved myself.
image

When the "Please enter password" prompt box shows up in Toad I'm given the option to enter a password or cancel. It allows me to enter a password and no matter what password I enter, the dialog box will go away and then after some time another dialog box will show up that then says "Error importing data, please check file format options -- Unable to load file".

I thought that there might be some special characters in the excel document throwing Toad off by chance so I broke the file into four parts to see which rows it failed on to try to pinpoint the issue. When this large excel document was broken up into 4 smaller excel documents it was able to run just fine so this password issue seems to be only happening when I try to import large excel files.

I've rebuilt/edited the import template several times and still get the same password error every time.

Lastly, I still have Toad Data Point 4.3.0.718 (64 bit) installed and weirdly enough this automation script runs just fine on this version and does not ever prompt the password error box. I wouldn't mind just switching back and forth between the two, however as a team we are trying to all move to Toad Data Point version 5 so that we can maintain standardization with our automation scripts as the scripts in version 4 are not compatible with version 5 and need to be updated to fit version 5.

Was checking to see if anyone has any tips or has experience this before. Any help would be greatly appreciated! Thanks for taking the time to read my long winded explanation :slight_smile:

As a user myself, I appreciate that you did some experiments (e.g. partitioning to smaller worksheets) to try to get a clearer picture of what might be causing the symptoms. It does appear that this is a bug. Would advise you to create a support ticket so Quest can track and document a possible work-around.

Also, the latest version of TDP is 5.4... does your scenario still happen in the latest version?