Toad World® Forums

Poor Code Completion performance on joins

Hi,

We’ve recently upgraded our TOAD from 5.3 to 6.1.

Everything seems fine except the auto completion performance while writing a join statement.

Code completion for selects from a single table is lightning fast, until a second table comes into picture with a join statement.

As far as I can see, TOAD is trying to get the links of the the tables in the shema based on their FKs and list them at top of the auto complete list.

As the shema gets bigger, the poorer the perfomance gets. Version 5.3 was performing better than 6.1 and writing queries without the help of auto complete costs us a lot of time.

Can anybody suggest a way to improve the perfomance or is there a way to prevent code completion from reading the table relations?

Thanks.

Hello,

To be honest both v5.6 and v6.0 of Toad for DB2 running on Windows 7 struggle with this concept at the best of times. It sounds like your installation works like mine does when freshly restarted and it is happy, after a few hours mine may just give a massive red cross in a box on the screen or simply not even try to auto-complete anything.

Any env for our DW has a rather large number of schemas and objects

I see under options > Editor > Code completion there is the ‘Include rarely used items’ option - I guess it stores a history and maybe un-ticking that would prevent it searching around. I am trying this on mine at the moment to see if that improves things.

You could try the above to see if that helps

Regards,

Richard

Hello Richard,

I’ve tried this option but could not get any improvement. I’ve even removed eveything but the tables using the object explorer filter but still no luck…