Toad World® Forums

Problem connecting to PostgreSQL

Hi.

I’m trying to connect to a PostgreSQL database, but failed. During connection, there is a warning stated that “Minimum driver version requirement not met. You will still be able to connect, however some Toad features may not be available.” (My version of PostgreSQL is 7.4.2)

Then, I just ignore the warning, and proceed. Connection looks successful, but i got this error message:

“Error while executing the query;ERROR: schema “” does not exist”

The schema available at my PostgreSQL is only Public Schema. At Toad Data Point Navigation Manager, I can see all the tables, but because of schema is , it will pop up error message “schema “” does not exist” everytime I tried to view the table’s content.

Thanks in advance.

Hello AzlanW,

It seems that you use very old PostgreSQL ODBC driver, which does not support ODBC protocol version 3.

Try to install some newer version: https://www.postgresql.org/ftp/odbc/versions/msi/

Libor

I also have problem connecting to Postgresql data source.

I downloaded and installed Postgresql ODBC drive (https://www.postgresql.org/ftp/odbc/versions/msi/ 64 bit version)

in Windows control panel I added ODBC data source: when I press test says: connection succesfull

I created new connection with new PostgreSQL ODBC data source but I got this ODBC error message: “The specified DSN contains an architecture mismatch between the Driver and Application”

(operartion system is Win7 64 bit, I tried both 32 and 64 bit ODBC driver, I use putty to build SSH tunel so Postgresql database is available on local machine (127.0.0.1) )

Toad Data Point is currently a 32 bit application and does not use the 64 bit ODBC that you downloaded. That is the error you are getting. A 64 bit version is in Beta right now.

If you can update to a current 32 bit Postgresql ODBC driver then that should solve your problem until we get the 64 bit product out.

-Mark

I got it: I downloaded psqlodbc-setup.exe from postgreSQL web page (psqlodbc_09_05_0400.zip) and installed. After I started odbcad32.exe and added as 32 bit ODBC data source, and after this it worked.

Excellent! I am glad you were able to get it working. Just let us know if you have any other questions.

-Mark

I already solved the problem.

First, I install the latest ODBC driver for PostgreSQL 9.6 at this link https://www.postgresql.org/ftp/odbc/versions/msi/

Then, I add System DSN at Control Panel\Administrative Tools\Data Sources (ODBC)

But, it’s quite tedious. Because one System DSN can only connect to one database, unlike Oracle or SQL Server where we can browse through all available Schema after one System DSN connected.

Thank you for your help, Libor.

Regards,

Azlan