Toad World® Forums

Problem with sync script creation in TOAD 14.1

I noticed generating a synch script from a schema compare, that selecting a grant on a pl/sql package also caused the pl/sql package itself to be included in the synch script. (this resulted in an incorrect version of the package being installed in our production environment)

Hi Wendy,

I tried to reproduce it by putting this procedure in the JDORLON schema of 2 different databases.

CREATE OR REPLACE procedure JDORLON.asdasd
(param1 in out number)as
begin
  null;
end;
/

In the source database only, I granted it to another user.

Then I ran schema compare of the 2 schemas - including only procedures and grants.

When comparison was done, I right-clicked to uncheck everything everything in Difference Details, then checked only the grant (under objects only in..., then grants).

The sync script only has a single grant statement, as expected.

Please let me know what I should do differently to reproduce the problem.

That was my best guess on what happened, so I'll have to keep looking. Thanks for checking.