Toad World® Forums

Problems with Subversion

I have the CollabNet Subversion client installed. As far as I can tell, Subversion is correctly configured in the global settings and the project settings. However, all Subversion operations fail. Some, like checkout, don’t ask for username and password. Others, like commit, do, but don’t work anyway. Regardless of whether I’m prompted for a password or not, I get the following:

Subversion command: “commit “D:\Users\KDean\projects\Client\Gateway\release-1.3\database” -m “Initial check-in””.

Authentication realm: <https://dev.example.com:443> Subversion Auth Realm
Username:

I have to do all my operations outside of Toad Modeler. Any ideas?

Hi,

please check your settings. We tested CollabNetSubversion-client-1.7.3-1-x64.exe
on Windows 7 – 64b and it worked fine.

Please activate or show Message Explorer (you can see there all the commands that go from TDM to SVN) and let me know what is displayed in Message Explorer when you run Refresh command.

Also, let me know how did you define Working Directory please.

BTW: There is a short instructional movie available:
http://modeling.inside.quest.com/entry.jspa?externalID=4524&categoryID=158

Regards,

Vaclav & TDM team

Here’s what I have in the Message Explorer window when I view the details of the first line. Note that this is the same (except for the command) as in my original post. I have verified that the username and password in the global settings are correct.

Subversion command: “status “D:\Users\KDean\projects\MyClient\MyProject\release-1.2\database\Models” -u -v”.

Description:
Authentication realm: <https://dev.example.com:443> Subversion Auth Realm
Username:

I turned on the “Non Interactive” flag in the project properties and now I have something different. Same thing if I also turn on the “No Authentication Cache” option.

Subversion command: “status “D:\Users\KDean\projects\MyClient\MyProject\release-1.3\database\Models” -u -v”.

Description:
svn: E170001: Unable to connect to a repository at URL ‘https://dev.example.com/svn/database/release-1.3/Models
svn: E170001: OPTIONS of ‘https://dev.example.com/svn/database/release-1.3/Models’: authorization failed: Could not authenticate to server: rejected Basic challenge (https://dev.example.com)

<?xml version="1.0" encoding="UTF-8"?>

Hi Kevin,

I’d like to ask you for sending me additional information. I would like to know:

  • What version of TDM do you have and use?
  • Did the previous command (Non Interactive option turned off) failed and if yes, what did you see in Message Explorer?
  • What what version of SVN client do you use? (We tested SlickSVN client and found no problem.)
  • Are you able to use another SVN client normally?
  • And finally are you able to run SVN.EXE with the parameters from command line successfully?

It seems to be a problem outside TDM, please make sure SVN is correctly configured. Here is a link to another discussion:
https://groups.google.com/forum/#!topic/subversion_users/O8KjuByLg6g
As you can see, there can be various factors causing problems…

I hope it helps,

Vaclav & Petr

I have TDM 4.1.5.8.

I have given you the output in both modes: non-interactive turned off and non-interactive turned off. Please see my previous posts.

I use CollabNet SVN client 1.7.

I haven’t tried another client and have no inclination to do so.

SVN.EXE works fine on the command line when given the same parameters.

I’m running all this under Windows 7 64-bit.

None of my other Subversion tools (command-line client, TortoiseSVN, or the SVN integrated into Eclipse) have this problem.

I have a similar situation:

I use TDM 4.1.5.8
SVN Server is ubersvn
SVN client TortoiseSVN
Windows 64 lokal and on server

Everything looks ok, but no data is written to svn.

I have no problems with tortoise and Ankhsvn in VS

Chris

SVN status “C:\Users{username}\Documents\Toad Data Modeler\Standard Installation 2\Projects\tdm2\Models\Test.txl” -u -v --username user1 --password pass1

Note: TDM doesn’t show username and password commands in Message Explorer for security reasons.

Hi,

we did additional tests with the following result: we were able to reproduce it only when username and password was not set correctly.

If username and password info is missing then cached user might be used. This might cause the problem. Please try to run the following command (modify path to the file and username and password) from command line from the directory where SVN.EXE is stored:

Another reason that can cause problems might be in unicode chars in name or password. Do you use unicode chars in username or password, please?

Thank you,

Vaclav & Petr