Remove automatic rowid inclusion

I often start in the schema browser to setup an query, and often that is enough for my needs, but if I need more advanced logic I copy the SQL using the dropdown and that continue in the editor.
I would love if ROWID would not be automatically included in the SQL that I copy.
I can understand if the ROWID column is turned on that it is included, but I never have that column turned on but still rowid is included in the SQL

We could maybe make an option to send just send the query to the editor (with/without rowid)...but the reason we include ROWID in the schema browser, even if the column is not visible, is that this is what allows you to edit table data in the grid. (so Toad can make queries behind the scenes like "update table BLAH set my_column = 'new value' where rowid = ....")

I understand, your suggestion would be fine for my needs.
Thank you

By the way....if you ever want to send a query from schema browser to editor, just hit F3 on the table name (it doesn't include any changes you've made to the query in the SB, but it does include all columns except ROWID)