Not include rowid in View/edit query schema browser

I never have rowid showing in my grids in schema browser.
However when i select View/edit query rowid is always included.
Would it be possible to not have it included ? only include the columns that are selected for the table?

ROWID must be selected in order for you to be able to edit the data in the grid. If you don't want to edit to the data in the grid, or want that disabled by default, go to Options -> Data Grids -> Data, and check "Default to read only queries". Then ROWID won't be selected.

Then, if you want to edit the data, you'll have to first uncheck the "Read Only" box on the right. The query will then re-execute and include ROWID .

Thanks for the response.
I frequently update the grid directly in the schema browser, so read only is not an option for me.
It is not a big deal, so I will just have to live with it.