Toad World® Forums

Results from Query Builder

Hello

When running queries from Query Builder I only get the first 1,000 results and have to scroll down to get the rest. I have my database option under number of rows to initially fetch as 50,000. Is there a way I can turn off the limit of it only bringing back the first 1,000 rows? When running a query from just an sql file it brings back all results. My Toad Data Point Version is 4 0 1 775

Thanks.

I am running Data Point 4.1.0.226 (64bit). Go to Options, Database, General. There is a box you can check called Unlimited on the top. I do not use the query builder I just write the code in the editor so I am not sure if it will work for the builder.

Hi David,

If you want to fetch more than 1,000 rows you have to go to Toad Options.

For this go to Tools Menu->Options.

Locate Database Folder->General

There is a parameter called “Number of rows to initially fetch in data tab”. Modify this to your convenience. be careful and take into consideration this could affect visualization performance and network traffic. You can check the “Unlimited” option and then you will bu using database parameter.

If you are connecting to an Oracle Database there is a specific parameter for this under the “Oracle” Database parameter.

Hope this could help you!

Regards,

Ronaldo.

Thanks very much.