Toad World® Forums

Save Grid Contents Running Extremely Slow


#1

Every time lately that I try to save the grid contents to an external file, it seems to take a really long time. I have noticed this in the past week or so. The only change to my work computer lately was the addition of a 2nd monitor.

For example, trying to export 65 records as an insert statement takes over 10 minutes to export!

I am wondering if there is some cache or similar that is getting filled up and I need to clear it out or something.

I am using TOAD version 9.5.0.31 (yes, my company has been too cheap too upgrade in a while).

Thanks in advance.

Julia


#2

I think in that version there’s a feature/option called ‘Clone
Cursor’ that you’ll see on the SaveAs dialog.

Try toggling it on/off and see if that has any affect.

It shouldn’t though as you say it happens on just 65 records.

The query it took to get your 65 records, that wasn’t also a 10 minute
query was it?


#3

In 9.5, the option was called “Display all exported results in
grid”.

If it’s checked, we take the dataset right from the grid. In this case, we
don’t have to re-execute the query, but the whole dataset will get loaded
into the grid…so for a large dataset, this could be bad.

If it’s unchecked, the query gets re-executed but it won’t eat up
all your memory even for a large dataset.

Based on what you’ve told me, it sounds like you want it checked.


#4

I looked and it actually is checked (Display all exported results in grid). I wrote the original message actually when it was still trying to export. It took longer than 25 minutes to do the export.

The query that I used to get the data set in the first place actually only took 125 msecs initially.

I’m starting to wonder if something is wrong with my computer.

Julia


#5

I’m not seeing this “Clone Cursor” option you mention. The query takes 125 msecs.


#6

Are there really only 65 rows in the dataset, or is it a larger dataset, and you
have selected 65 rows in the grid to export?

If the latter, uncheck that checkbox.


#7

Does it do this for any file type you save to (excel, text, …)? Are you saving to a network drive?


#8

Yes, it does it for any type of file I try to save. Seems to be worse with the “insert statement” option but I have tried excel also and it does take a LONG time.

This is indeed only a 65 record dataset that I’ve pulled out of the database.

Also of note, I can’t seem to uncheck that option (Display all exported results in grid). It is greyed out (but checked).

I also should mention that my Toad has been taking longer to start up initially too lately.

Thanks,
Julia


#9

Sorry, I forgot to add that I am trying to save the file to my C: drive.


#10

You don’t happen to have a McAfee virus scanner do you? If so, try
disabling it temporarily to see if it has any effect.


#11

No, we have Symantec AntiVirus running. This has not changed in the (almost) 6 years that I’ve worked here and used TOAD. I don’t have the option to temporarily disable it, they don’t give us the ability to do that.


#12

You could try closing Toad and renaming your Toad.ini. Then when you start Toad
again, its options will be reset.

Another thing you can try, if you don’t have any saved actions, is try
renaming ToadActions.dat (again, do it while Toad is not running).

Both of these files are in your User Files directory. You can rename the files
back when you are done if you want.


#13

WOW. Thank you so much John! The culprit was the ToadActions.dat file. It was 40 MB. I backed it up elsewhere and removed it as suggested and exports are going nice and quick now! Toad is still starting up a little slow but that is not as much of a concern.

Thanks again! This makes me VERY happy!

Julia


#14

You’re welcome.

If you go to Options -> Editor -> Display, and uncheck everything under
“Syntax Highlighting”, Toad will connect faster.