Toad World® Forums

Schema Browser - Sort

Sort order in Schema Browser ignores '_' symbol in names.
For example, tables shown:
...
T_EC00_VYTR_SPIRIT_TURNOVER
TICKETS
TMP_LSTCD
T_RG02_B21COUNT
...

LIKE without ESCAPE

Well. What now?

I can't reproduce this. This is how mine sorts:

Did you apply any custom filter, and what is set for "order by" here?

If your "order by" is "Name Asc" and the column header in the schema browser isn't clicked to sort there, then Oracle is doing the sorting, not Toad.

Here you can see schema browser not sorted by clicking column header:
image

Here you can see schema browser is sorted by clicking column header:
image

See the triangle? You can click there for Toad to sort it, or CTRL+Click to turn that off.

I not use custom filters.

In the Schema Browser Treeview mode, sorting is always done by Oracle.

Try this in the editor and see what the sort order is (you may need to remove some of the columns selected for older oracle versions):

Select t.table_name, user as owner, t.cluster_name,
t.partitioned, t.iot_type, t.tablespace_name, t.last_analyzed, round(t.num_rows) num_rows,
t.initial_extent, t.degree, t.logging, t.cache, t.buffer_pool
, t.monitoring, t.temporary, t.table_type, t.table_type_owner, t.nested
, t.Compression, t.dropped
, t.compress_for, t.flash_cache, t.cell_flash_cache, t.segment_created
, external
from sys.user_all_tables t
where 1=1
order by table_name;

If the order there matches what you see in the Schema Browser, I suspect that your setting for NLS_SORT is not Binary.

Thank You, John.

1 Like