Toad World® Forums

Schema compare - disable auto format code in scripts

Hi!

I have Toad for SQL Server 6.8.2.9 Professional.
How to diasable auto formating code in scripts after schema comparing?
I want to leave my original code.

Hello bartosz.chojnacki!

Unfortunately, you can't change auto formatting in schema compare scripts. I created task 1. TSS-1654 for it. We will add thea same functionality like in Editor for formatting

In any case, during compare Schema Compare uses original code. Auto formatting uses only in presentation

Hi,

Thank you for reply.
TSS-1654 will be add to SQL Server 6.8.2.9 or SQL Server 7.0 beta?
When can i except TSS-1654?
SQL Server 7.0 beta not working for me - Schema Compare hangs and crash when comparing

Could you provide more details about the crash?
Support Bundle or/and schema snapshots of databases

TSS-1654 will be implemented next few weeks, I suppose

Hi bartosz,

Could you send Support Bundle or/and schema snapshots of databases to us? that will be very helpful to reproduce issue for us.

Thanks
Michael.Luo@quest.com

Hello

I installed official version 7.0 and schema compare still don’t work - crash.

Comparing in 6.8 is ok.

Hello,

Thanks for your update.

Could you send us Support Bundle file to help us analyze (Help menu->Support Bundle)?

or you can send Support Bundle file from: %userprofile%\AppData\Roaming\Quest Software\Toad for SQL Server 7.0\ToadSupportBundleToad for SQL Server.zip

Thanks,
Michael

Hi,

When you can expect an implementation of TSS-1654?

Hi,

I looked on this task this week.
Just turn off option Ignore whitespaces during comparison and you will see objects with raw bodies

You can set this option for Schema Compare by default in Options>Schema Compare>Comparison Options

Vasiliy