Toad World® Forums

Set Default Schema


#1

Does someone know how to set a default schema when I login using Toad for Oracle 12.12. I tried the following but seems like its not working.

Thanks-

Rajbir.


#2

Go to any schema dropdown in Toad.

Choose the schema that you want for defailt.

Right-click on the dropdown, then choose “Set as Default Schema”


#3

This seems to be a problem for me as well.

The Schema Browser window will default to my default schema, but the Editor window doesn’t seem to keep the value.

Also when I right click the schema dropdown on the Editor window it asks me again to clear the default of my username instead of the default schema I chose before.


#4

I am also having issues with the default schema. Sometime in the past few releases this behavior has changed.

In the past going to View, Toad Options, Oracle, General and then setting the Default schema for connection to <tns_name_entry> or @<tns_name_entry and setting the user the editor window would pick this up and use it for a query without needing to select the schema from the schema dropdown. Now anytime an editor is opened for the connection, I have to select the default schema from the drop down. This defeats the purpose of setting the default schema in the Oracle, General settings. Does anyone else have this issue in Toad for Oracle 12.12.0.39?