Toad World® Forums

While using Team Coding, if 'Execute Snippet' is used, it completely by passes Team Coding

Hello,

We are using Team Coding with Git. If a new object is created using the ‘Execute Snippet’ (CTRL+ENTER or SHIFT+F9) it will complete bypass Team Coding. The object does not need to be locked, no new file is created in Git and no new object is created in Team Coding. This seems like a problem to me. The only workaround I can find is to modify the ‘Execute Statement’ short cut and set it to ‘CTRL+ENTER’ or whatever the developer would normally use so that the modifications are actually stored in Git.

Is this a bug? Any other suggestions on how to avoid this problem?

I’m using Toad 12.9 and Toad 12.10 - it occurs in both.

When you’re running the script, are the objects fully qualified with the controlled schema name? Or are you logged in as the controlled schema? This may make a difference

I apologize, I read “execute snippet” as “execute script”. Yes, execute snippet, Ctrl+enter, Shift+f9 (all the same thing) bypasses team coding.

I believe this was done by design some time back, but it doesn’t seem to make much sense anymore. We will have to see what the developer has to say about this one.

Thanks Brad. By the way, the “workaround” I thought I had does not work either. It seems you are unable to override the CTRL+ENTER short cut. (At least I have not found a way)

I’m attempting to transition some long time Toad users to adopt Team Coding, but for folks who use this short cut multiple times daily, it will be a tough habit to break. Asking them to change the way they work doesn’t always get a pleasant response

I can certainly understand this, but be aware, there is now an option to make F9/Execute/compile work similar to Ctrl+Enter/Shift+F9. Check out Options > Execute/Compile > Treat blank line as statement terminator. As far as overwriting the shortcut, R-click on the main toolbar and select “menu shortcuts”. Look in the “Editor” category and you can configure your shortcuts there. You can map Shift+F9 to “execute statement” and delete the mapping for “Execute Snipped”.

Brad,

Thanks for the information. I was able to override the Shift+F9 shortcut but I can’t seem to override the Ctrl+Enter shortcut (which is the one my developer is currently using).

Unfortunately that one can not currently be overwritten. The proper fix on our side is to have Team Coding respect Shft+F9/Ctrl+Enter

Yep, this does look like a bug. This should be fixed in tomorrow’s beta.

Thanks for bringing this issue to our attention!

-John

Excellent! Thanks John.