Toad World® Forums

"Sign in with Google temporarily disabled for this app"

When trying to reauthorize an existing connection to Google Analytics (or trying to set up a new connection), I'm getting the error "Sign in with Google temporarily disabled for this app". From what I can see in other apps, the developer has to authorize the app with Google. Is there a fix for this?

I tried it under datapoint 4.3 and then upgraded to 5.3 and am still getting this error.

Hi Do you see above google login dialog when you connect to google analysis? Just click "allow" to connect to google analysis.

If you still meet the login issue when connect to google analysis, please send your screen shot of the error prompt .

I don't get to that authorization screen. I assume Quest would already be authorized for my account because I used to be able to connect. I only get these 3 steps

Hi, as you have connected to google analysis before, please try below steps to check if they work for you,

  1. Log in google analysis via your google account, Top Right Menu : Google Account -> Manage Account, then choose "Security" in the left panel, you may see the Quest Software show in your "Third-party apps with account access"

2)Click the Quest Software, then it will jump to the app detail, click the "REMOVE ACCESS" button
image

3)Create a new google analysis connection in TDP, after you input your account, below warning screen maybe shown

  1. Expand the Advance link and click the Go to Quest Software

5)If below screen show up, just click "Allow"

Quest isn't listed under apps with 3rd party access (step 1 & 2) so I can't remove the access. I'm still getting the same error message "Sign in with Google temporarily disabled for this app" when I try to create a new connection. When I try with a different Google account (that has never been used in Toad before), I do get the "This app isn't verified --> Advanced" screen, but not when I use my previously-used account. How can I get Toad to "forget" my account?

We are working with Google to resolve them(This app isn't verified and Temporarily disables for this app), but don't have an estimate on how long that will take.
I'll update here as soon as we know more.

For "Temporarily disables for this app", according to the google doc, it should be also related to verified app, but it can not explain why only your previously used account not work, but other accounts work. We also test several existing/new google account for Google Analytics connection in TDP, cannot reproduce this issue. We are also checking this with google.

Hi, we finally get Toad Data Point verified by google , so the "This app has not been verified yet " issue has been solved, please try again to login google analytics in Toad Data Point.

Yay! It works, thank you!