Toad World® Forums

Simple select query while connected to Cloudera Hadoop via Apache Hive connection gives error


#1

Using TDP 4.3 and I can view the tables in Schema Browser, even see the data, but when I run a simple select * from schema.tablename where condition, I get below error.

Hive error: Error while processing statement: FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.mr.MapRedTask

Hive queries should use table aliases and fully qualify all columns. The current statement may be missing one or more elements.
IE; SELECT a.col1 FROM table a.

If I run the same query in the Hue (Cloudera webbased interface), it runs without any errors.

Really disappointing as I was banking on using TDP for accessing data from Cloudera Hadoop.


#2

Hi,

looks like you are right and there is some issue with our Apache Hive connection. I created task for it QAT-13168 and we will take a look on it. You can check this number in our release notes.

There is second thing which I would like to ask. Because you are using Claudera did you try use our Impala connection in TDP? I tried connect with Impala ODBC driver and I was able use all SQL statements correctly.

Filip


#3

I did not try Impala ODBC Driver as that would involve I think ODBC Driver on the CDH side as well and our admin needs to be involved and they are not interested. Funny thing is I tried the same query next day and it worked.

Still 2 issues. A background query trying to retrieve table and column data keeps running for really long. I think TDP tried to retrieve information from all the schemas we have.

Also, the Editor keeps losing the default schema from the drop down at the top after you run a query. Initially, it defaults to whatever schema you are looking at in Object explorer on the left, but then it blanks out after the first query you run. You then have to reselect or use a USE schema_name statement, which does not work either. I have used that with Hortonworks HDP before, so not sure if CDH supports it or not or if it is a TDP issue as gives syntax error.


#4

We only support Impala using their ODBC drivers (which they have two). Apache Hive uses Apache API calls and these are not the same.

The execution issue you mention, where the schema drop down is cleared after running is an issue that has been fixed and is in the current Beta.


#5

Created KB 259475 with a workaround that helped the customer.