Toad World® Forums

Spurious ORA-00942 when editing a table

Hi team – these forums have been pretty quiet recently so I thought I’d throw one out here. I’m on a 11.2.0.3 database running 32 bit SQL Navigator 7.2.0.3912 on a 64 bit Windows 7 laptop. Every time I edit a table, I get a “ORA-00942: table or view does not exist” error in my output window. It has no affect in my ability to edit the table so I make my changes and go on my merry way, but ti would be nice to get rid of it. Any thoughts where to look or what table/view it is referring to? Thanks much!

Hi MarkM in PA ,

Did you get exception error when you edit a table every time?

For now when you click on output error message, you only get oracle information.

Regards,

Michael

Hi Michael

I tried 3 different databases (10g and 11g) and a bunch of tables and each time I edited a table I got that error in the output window. It doesn’t come up on editing views, just tables. I tried clearing the “Enable using DBA Views” checkbox which is the only option checked on the Oracle Logon box, but that made no difference. As I mentioned, it has no impact, I can edit the tables fine, but it would be nice if it didn’t come up each time.

I ran SQL Tracker and it is issuing two select statements when I edit a table:

SELECT tablespace_name FROM sys.DBA_TABLESPACES WHERE contents = ‘PERMANENT’ ORDER BY 1

and

SELECT owner, a.object_name, a.object_id, a.created, a.last_ddl_time, DECODE (a.status, ‘VALID’, 0, ‘INVALID’, 1, 2) status
FROM sys.all_objects a
WHERE a.owner = ‘MYSCHEMA’
AND object_name LIKE ‘MYTESTTABLE’
AND object_type = ‘TABLE’

The first select is failing as my user doesn’t have DBA privileges. The same select would work fine if it used user_tablespaces instead.

Is there a way to not have it make that first select statement?

Have you accidently ticked the check box “Enable using DBA views” for the connection of this user?

Hi Torsten, that was my first thought also so I had tried with the DBA views checked and unchecked and found no difference. I just verified again that I still get the error when logging in with the “Enable using DBA views” clear.

Michael and Team – anyone have a suggestion or thought?

Hi MarkM in PA,

Sorry rely to you so late

The error occurs when current logged in user doesn’t have privilage to use DBA_TABLESPACES, Our team is working on this issue, we will fix it in next v7.3 beta.

defect ID SQLNAV-1885

For now, you can assign DBA privilage to user.

Regards,

Michael

Excellent Michael. Thank you for creating the defect. I can’t give DBA privilege to these users, but it does not affect the ability to do work, it’s just a nuisance. It will just be nice to have it go away in 7.3. :slight_smile:

Hi MarkM in PA,

Pls try to download our current v7.3 beta, it seem that has been fixed this issue.

Thanks,

Michael

I’m in the middle of a project right now and don’t want to mess with my SQL Navigator, but I’ll download and try the beta as soon as I wrap up here.

Thanks