Toad World® Forums

Toad data Point 4.3 ORA-00942: table or view does not exist

#1

When i run query in toad data point 4.3 get error ORA-00942: table or view does not exist but the same query work fine in toad for oracle 12 on same PC. any idea why this happening?

#2

Can you give more details?
Are you logging in the exact same way (and to the same database instance) with both products?
If logging onto different databases, even the same username can have different privs, allowing the user to access some objects on one database, but not the other.
Toad solutions never bypass the security that DBAs have set up on the database, so users may be constrained based on their privileges. You may want to check with your DBA for more information.

#3

Did you fully qualify your table or view? IE: select * from schema.object_name? If not, try adding the schema. The Oracle sessions are pointing to a default schema and if you don't fully qualify your table with schema name it will only look where that session schema is pointed.

#4

Thanks, it works now