Toad World® Forums

SQL Monitor cannot start, blank window on start

Hello,

I have a problem with SQL monitor from toad.
Whenever I start "SQL Monitor", either from toad or directly from "C:\Program Files\Quest Software\Toad for Oracle 2020 R2 Edition\Toad for Oracle 14.0\SQLTracker\sqlmondb.exe", the programm starts, but I get an empty transparent window.

I check the logs under: "%Appdata%\Quest Software\SQL Tracker\sqldbmon.log", where I the following entries:

08/19/2021 16:04:51.143 ( 2552): () 55 (lvl=02) (LE=126) -- Could not load QP5 dll; error=126 (Das angegebene Modul wurde nicht gefunden.)
08/19/2021 16:04:51.275 ( 2552): () 219 (lvl=03) (LE=6) -- QuestRIStart

The dll QP5.dll is available "C:\Program Files\Quest Software\Toad for Oracle 2020 R2 Edition\Toad for Oracle 14.0\QP5.dll", but nowhere else.

I have the same issue with the latest version of Toad (14.2).
I could not find anything on google about this problem, maybe someone here knows more =)

  • Theo.

Hi Theo,

I just tried with both Toad for Oracle 14.0, as well as Toad for Oracle 14.2. In both cases, sqldbmon was able to launch, load QP5.dll, connect to Toad's session, and report on queries I ran within Toad for Oracle.

SQL Tracker will look for QP5.dll first in its current directory, then in the parent directory (for when it's packaged with Toad for Oracle), then in the system path. Your error message says that the module could not be found even though you mentioned it does exist within the parent directory. As a result, I have a few quick questions based on your post:

  1. First, just to verify, is the executable in your SQLTracker folder really spelled "sqlmondb.exe" or "sqldbmon.exe"? It should be the latter. If it's not the latter, it may not be a genuine executable from Quest Software. You can right-click on the file and go to Digital Signatures to verify if it was signed by Quest.

  2. Do you have any security restrictions that might prevent an application from reading from the Program Files\Toad for Oracle directory on your computer?

There are a few things you can try that might help work around the issue you're seeing:

  1. You can try adding the Toad for Oracle folder to your PATH variable just to see if that makes any difference?

  2. You can try manually copying the QP5.dll into the SQLTracker folder and seeing if it recognizes the file.

  3. You can also try reinstalling your Toad for Oracle installation (or doing a repair) to see if there are any missing files that were not correctly installed.

The fact that Toad for Oracle works, but SQL Tracker does not, suggests it's simply a matter that SQL Tracker can't quite load the necessary DLL. Feel free to give these a shot and let us know if that helps to resolve the issue you're seeing.

Thanks,

-John

Hi John,

thank you for your help ! I managed to fix the issue.
The problem is that I have oracle client 12.2 32bit and oracle client 19c 64 bit installed. (sadly the 32 bit is necessary for development purposes...).

Even though during the installation of Toad 64bit it showed that it was using the oracle 64bit client, and that the client 64bit was the only client in PATH variable, there was a conflic with that.

I changed the oracle client in path back to 32bit, installed the 32bit Toad for Oracle, and now its working.

Further notice:
With the 64bit Toad and 64bit oracle client, when starting sql monitor, I got the error described above.
When I copied "QP5.dll" into the folder where sql monitor was, I got the following error:
8/19/2021 13:23:46.191 ( 11648): () 219 (lvl=03) (LE=6) -- QuestRIStart
08/19/2021 14:05:28.217 ( 2872): () 55 (lvl=02) (LE=193) -- Could not load QP5 dll; error=193 (%1 ist keine zulässige Win32-Anwendung.)
(in english: %1 is not a valid Win32-Application).

Best regards,
Theo.