Toad World® Forums

SQL Navigator 6.2.1 RegeExp doesn't work in window Find and Replace

Hi
I have tried to find some function with regular expression template function\s+\w{1,30} it is working properly in SQL Navigator 5.5 but is not working in 6.2.1.

Thank you
Artem

Hi Artem,

The bug was logged and will be fixed soon.

Gwen

Gwen
Thanks a lot

regexp search is still not working Build 6.3.0.1828
when it will be fixed?

Thank you
Artem

SQL Navigator 6.3.0 1828 has the same issue

Hi Artem,

Unfortunately, the editor component we use since 6.0 relies on a different regex library than 5.5. We have logged the issue but it will be fixed after 6.3.

Regards,
Roman

Regexp in Find /Replace windowis looks better now Build 2086 but for example Find \n still does not work

Thank you
Artem

Thanks reporting this.
We already fixed some of the regular expression in code editor, but there is still some more regular expression is not supported by nav.
eg:
\n
(?:pattern)…
(abc)(aa)\1\2

I have raise a CR . Will work on it as soon as we can.

Thanks a lot.
Lyla Su

This is still an issue in 6.7. Most specifically and problematically for our use is that tas don’t work. Either with our without regular expressions.

So checking regular expression and searching for:

\t

Finds nothing.

Likewise, copying a tab character from the text into the find dialog and searching normally (regular expressions off) doesn’t work either.

Hi Peter

Yes you are correct \t is currently not supported in 6.7, seems we missed this in our work we did on 6.5

I have raised a story (PT28717483) for this so we will aim to get it fixed in our next release.

regards
Lidia