Toad World® Forums

SQL Results disappear immediately after SQL processed


#1

Hello I am new to this forum and updated today to 12.5.1.1 freeware version as the previous one was expired.

First issue I discovered is that the result set of a SQL Query is shown for some milli-seconds and then the result disappears and the data grid is empty - so basically there is no way to view the results and work with them - with the previous version it was working fine.

Does somebody experience the same issue or is there any option I need to set or is this a feature of the new freeware version (which would make it useless).

Thanks a lot for any help in advance


#2

Are you able to query from any table at all (even a simple table)? What about when you use the Schema Browser - does the data show in the data tab?


#3

I tried this now and get an ORA-65535 immediatelly when trying to open the Schema browser aor use the F4 on an existing table Name - it seems that Toad has difficulties to read the Schema Information.

This happens for all the Schemas.

FYI on the same laptopn with the same databases all was working fine with the previous Toad Version - this all happens now after the update to 12.5.1.1 .


#4

Can you tell us more about your environment? Are you running 32 or 64-bit freeware? What Oracle client are you using? Is it 32 or 64, instant or full? What O/S are you running on?


#5

Thanks for the hint to look at the ‘bit-versions’ - I am running Win8 64bit, Toad 64-bit Freeware and now I installed 11g-64bit Oracle Client - and it works somehow.

There is still an issue with the OCI.dll which is expected by the Toad in the BIN Directory, but not located there after the Oracle-Client Installation.

However I made it work - still not ideal and still surprised what within Toad changed in the new Freeware Version.

Thanks again


#6

Anyone else seeing ORA-65535 when using schema browser? Completely non-functional for me with the latest update. Am I missing something? Happy to provide any details necessary in order to get this working again.

64Bit Toad Freeware 12.5.1.1 with 64Bit 11.2 Client.

32Bit Toad Freeware 12.5.1.1 with 32Bit 10.2 or 11.2 Client


#7

I haven’t been able to replicate. What specifically are you doing in the Schema Browser?


#8

As stated above I experienced the same - the previous frewware Version was working fine.

I had installed the oracle 10g 32 bit Client my Windows 8 64bit - and then got the strange behaviour after the toad update.

I only could resolve it by having installed the 11g 64bit Oralcle Client in Addition to the 32bit 10g Client (wihotu that it is not working :frowning: - you might have different ‘root-entries (entries from the registry’ to choose in the toad Login area - try other than the ‘Oracle root’ please also.

This is all strange and is causing Problems with other applications now, but the toad is working.- wish I could still use the previous toad Version.


#9

The error you report seeing: ORA-65535 is not something Toad can cause, it’s a known Oracle bug with some versions - but not 11g R2 - so here is the Oracle doc copied from oracle support site - I think you have a oracle client or server issue. And yes I get it only happened when you uograded toad - so I have no idea why this is happening:

Sqlplus SSL Connection with PKCS#11 Wallet Fails with ORA-65535 on Windows Client (Doc ID 758419.1)
To BottomTo Bottom


Modified:02-Mar-2009Type:PROBLEM
Rate this document
Email link to this document
Open document in new window
Printable Page

In this Document
Symptoms
Cause
Solution
References


This document is being delivered to you via Oracle Support’s Rapid Visibility (RaV) process, and therefore has not been subject to an independent technical review.

APPLIES TO:

Advanced Networking Option - Version: 10.2 to 11.1.0.7
Microsoft Windows

SYMPTOMS

You have configured SSL connection to the Database server with PKCS#11 wallet. And while trying to login from sqlplus from windows client it fails:

`E:\oracle\product\11.1.0\db_2\NETWORK\wallet>sqlplus /@db10g1

SQL*Plus: Release 11.1.0.6.0 - Production on Wed Jul 9 19:38:39 2008

Copyright © 1982, 2007, Oracle. All rights reserved.

ERROR:
ORA-65535: Message 65535 not found; product=RDBMS; facility=ORA
`

This issue does not occur with PKCS#12 software wallet.

Sqlnet client trace shows the below:

ntzGetStringParameter: entry ntzGetStringParameter: exit ntzGetStringParameter: entry ntzGetStringParameter: exit ntzscr: ntzSetOid failes with error: 562. ntzGetStringParameter: entry ntzGetStringParameter: exit

CAUSE

This isssue is the Bug 6193802

SOLUTION

Apply the patch which contains the fix for the Bug 6193802. The below Windows Budle Patches include the fix for this bug.

10.2.0.3 Patch 13 and above.
10.2.0.4 Patch 3 and above.
This fix will be included in 10.2.0.5 Patch Set.

11.1.0.6 Patch 11 and above.
11.1.0.7 Patch 2 and above.

Refer Note 161549.1 for details on Windows Bundle Patches.

REFERENCES

BUG:7311014 - SSL CONNECTION WITH PKCS#11 WALLET FAILS WITH ORA-65535 ON WINDOWS 11.1.0.6
BUG:6193802 - SQLPLUS REPORTS ERROR WHEN USING PKCS11 WALLET WITH RDBMS 10.2.0.3 WIN PATCH 6