Toad World® Forums

"SQL Server Database Error" when attempting to view tables in new SQL Server connection

When our group was running a trial version of TOAD Data Point, our connection to our server through the SQL Server worked fine. Since then, we purchased the product, but there was a lapse of a few weeks, and during this time the server migrated.

We were able to make the new connection, and everything appears fine, until we attempt to open the tables. Then we get the following error:

Database Error

X SQL Server Database Error

VIEW DATABASE STATE permission denied in database ‘X’.
The user does not have permission to perform this action.

Here’s a screenshot:

Database Error.jpeg

We can get to this database and work with these tables in Microsoft Access, and we can also connect with these tables using the ODBC Generic connection, although we want to keep our data as SQL Server-parallel as possible. It worked before, so we aren’t sure why it’s no longer working.

Anybody know what gives?

Thanks in advance.

That’s an SQL Server permissions error.

That said, I’ve noticed - through auditing and extended events - that TDP executes some background SQL every time it connects to a database - SQL Server or otherwise - and that is probably the source of your error.

I’m not sure if the trial version doesn’t do that, since I’ve never used it, or if perhaps something has changed in your environment.

Thank you for your reply. I’m not sure how to resolve it if that’s the case. It turns out our access to the old server (which we are not to use under any circumstances) still works fine.

And we can access the tables in the new server in Microsoft Access and SQL Server Express.

My coworker did find there’s a version difference if she hovers over the two in TOAD:

NEW ONE:

SQL Server VERSION 12.0.4213.0

OLD ONE:

SQL Server VERSION 11.0.5623.0

Could the version numbers have anything to do with why TOAD seems to no longer be compatible with our migrated database?

If it is a SQL Server permissions error, how can we open the database up in SQL Server?

There’s no difference between trial version and commercial version of TDP except for licensing.

The issue here is related to the new server you are trying to connect to. Toad need to have data read permission to the server with your login. Please contact your DBA request the same permission with your previous server.

That would be my first thought as well, except that I can see and query the tables in Microsoft Access and SQL Server Management Studio Express. Would I be able to do this if it’s really a permissions issue?

(It’s also the first thing we checked, but the people who migrated the data didn’t seem to have any inkling regarding why there would be an issue with our access to the tables.)

I think I recognize this issue and it is fixed in our TDP 4.0 current Beta. Can you download and try?

I confirmed this was entered as QAT-7312 and was fixed about a month ago. The fix is in the TDP 4.0 Beta.