Toad World® Forums

[TDM 3.1.5.6] ORA-00942 in RE


#1

Hello All,

I am getting the following error while Reverse Engineering Oracle 10g database

Source: CS3 - Internal error
Script: REDataMigratorDBOR
Description: ORA-00942: table or view does not exist

Row: 4956
Column: 5

Callstack:
REDataMigratorDBOR

the wizard completes Reversing users… and Reversing roles… but fails on Reversing table details…

The RE is done under the user with DBA privileges

Any help and/or hints would be appreciated


#2

Hello,

The problem occurs during loading of the system table ALL_XML_TAB_COLS.

To avoid this, please do not select checkbox “Load XMLType Column Properties for Tables”. It should work fine then.

For further verification, we would like to ask you for the following information:

  • exact version of Oracle db you use,
  • please check out if you have all the necessary privileges to load this table.
    Thanks for the details.

Regards,

Vladka + TDM Team


#3

Hello vladka,

thank a lot for the prompt answer. Unchecking the checkbox solved the issue.

Oracle Database 10g Enterprise Edition Release 10.2.0.3.0 - 64bit

I cannot check the second option cause we do not have this view at all. As far as I remember it is an optional view installed as a part of XDB.

Best regards,
Igor Karp


#4

I am having the same problem with TOAD 3.4.16 on 10.2.01.

I’ve deselected everything except ‘relationships’ and ‘load all objects for selected schema’. I don’t get any tables in the selection window, nor any results after executing
it.

Thanks,
CML


#5

Hello,

What objects will be loaded is defined on page What to Reverse. If you deselected all (except for relationships), nothing was loaded. Neither were relationships, which is ok. Why? - Because if you want to load relationships, you have to select also tables (but you deselected them).

If you have any questions, please write me back. Thanks.

Regards,

Vladka