Toad World® Forums

TDM Generate Change Script Function Suddenly Stopped Working - Produces Empty Alter Script

Hi,

I have upgraded to the latest version and the Generate Change Script has worked fine a couple of times (and has always worked in previous versions), but I have just run it today and it has found the changes between model and db that I was expecting - however, when completing the wizard to create the alter sql script, an empty file is generated.

I have never seen it do this before and as there is no error, I have no idea where to start looking!

I thought maybe there might be something in an error log, but although I did find a log folder there was only one log in it from a couple of years ago.

Is this a known bug and is there anything I can do?

Thanks

Dan

Hi Dan,

Are you still working with SQL Server 2008 model/database or are you using another database platform/version? And are you still using TDM 5.5, or have you updated to the latest Beta version?

Could you please take a screenshot of each section of the Generate Change Script wizard so we can see your configuration?

We have seen no such problem before, it’s also a bit difficult to pinpoint since there is no log available. But you could try checking the Log Progress to File option in Comparison Settings of the wizard and then sending us the file (e.g. “C:\Users*username*\Documents\Toad Data Modeler\Logs\ConvertorSync.log”).

Regards,

Lukas

Hi Lukas, Apologies for taking so long to reply to this!

I am using v5.5.3.20 - I don’t tend to use the betas other than to test fixes as I do not want to risk messing up my model file. It is still SQL Server 2008 that I am working with.

The screenshots and the log file are going to be a few MBs - should I try to send them zipped to you by email?

Cheers

Dan

Hi again Dan,

Yes please, send me an email with the zipped screenshots and log (lukas.knapek@quest.com) and we’ll see what we can find out.

Regards,

Lukas