Toad World® Forums

TDM Package Paths


#1

Hi,

TDM 3.4.15

I am trying to set the Package Path to a shared drive so that all users can access the same customisation.

I set the Package and Metamodel paths then closed TDM.
When I restart TDM I get “Access violation at address 00E938DE in module ‘TDM.exe’.
Read of address 00000000”.
I then have to uninstall and reinstall TDM 3.4.15 to get the default path back.

How can I set these paths?

Regards
Malcolm


#2

Hello Malcolm,

You can define the package path to a shared drive, however, you have to preserve the default structure. I mean you have to have My Package.txg file there and the Metamodels folder.

Default path is:
C:\Documents and Settings\user name\My Documents\Toad Data Modeler\Installation Name\Packages{DCB5CB9B-CF65-4350-86B5-285D246FC5AC}
As you can see, there is the Metamodels folder and My Package.txg.

Shared drive - example: T:\PACKAGES where you copy the Metamodels folder and My Package.txg.
Path to the shared drive in Options | Paths | Advanced tab:
Path to Packages: T:\PACKAGES
Path to Metamodels: T:\PACKAGES\Metamodels

Please let me know if it works fine for you. Thanks.

Regards,

Vladka


#3

Hi Vladka,

That is how I set my paths up;
Z:\MSS_Databases\TDM\Packages\Metamodels

I think I created the folder structre then copied the files.

I recreated it without the Metamodels folder, then copied the contents of C:\Documents and Settings\user name\My Documents\Toad DataModeler\InstallationName\Packages{DCB5CB9B-CF65-4350-86B5-285D246FC5AC} into Z:\MSS_Databases\TDM\Packages. This now works fine.

Thanks
Malcolm


#4

Hi Malcolm,

Fine. Thanks for letting me know.

Have a nice day.

Vladka