TDP 3.2 Creating Transactions

I’m new to TDP and still haven’t figured out the idiosyncrasies. One of them is that TDP creates a transaction whenever it exec some queries. Is this a bug? If a feature, how can it be turned off?



P.s. We’re using SQL Server 2008.

Message was edited by: Dan Clark

Hi Dan,

Can you please give us more details what exactly you are doing in the product?
are you in SQL Editor running queries? if so please pay attention to the status bar left corner - there is an option “AUTOCOMMIT”, what’s your setting there?


Thanks for replying. Yes, I’m in the SQL Editor running queries.

I’ve seen the AutoCommit option, but wasn’t exactly sure what it was doing. Of the several query tabs that I have open right now, one had AutoCommit = off and the other query tabs were on.

I’m running queries in a Data Warehouse environment. Normally we do not use transactions because the risk of impacting other processes with a tranasaction is higher than the risk of a dirty read. Therfore…

One concern I have is that TDP is automatically creating a transaction for each query. If so, I need to turn off this feature.



Hi Dan,

Just to clarify Autocommit option in toad:
Autocommit ON equals to every script execution will be sent to database as complete transaction, user shouldn’t worry about committing it.
Autocommit OFF mean user should keep in mind all of his transactions (usually one per sql editor) and commit/rollback them manually then needed.

So your request sounds like you do not want toad to issue transaction command at all, correct?