Toad World® Forums

TDP 3.3 is running schedules twice. Running 3.3.0.1543 on XP. If I run interavtively in TDP it runs just once. Did not have issue with 3.2.


#1

I created a simple e-mail script and scheduled it…it runs twice! I am running


#2

Let me test this and see if we can reproduce.


#3

I tried to reproduce it on XP with 1543 pro build. I created simple script with just an e-mail activity in it. Was it what you’ve tried to do? Works fine for me. Are using pro or base? Is it still reproducible? If it is - can you send your script for review?

Thanks,

Igor.


#4

Igor,

I am using PRO, but a special build from support. They were able to replicate, so it may be just inherent in this special version.

Thanks

Carl Roth|** Corporate
Data Solutions**

Business Intelligence|Communications
|Phone: 972.578.6728|carl.roth@xo.com|

From: Igor Manokhin [mailto:bounce-IgorM@toadworld.com]

Sent: Monday, July 29, 2013 1:23 PM

To: toaddatapoint@toadworld.com

Subject: RE: [Toad Data Point - Discussion Forum] TDP 3.3 is running schedules twice. Running 3.3.0.1543 on XP. If I run interavtively in TDP it runs just once. Did not have issue with 3.2.

RE: TDP 3.3 is running schedules twice. Running
3.3.0.1543 on XP. If I run interavtively in TDP it runs just once. Did not have issue with 3.2.

Reply by Igor Manokhin

I tried to reproduce it on XP with 1543 pro build. I created simple script with just an e-mail activity in it. Was it what you’ve tried to do? Works fine for me. Are using pro or base? Is it
still reproducible? If it is - can you send your script for review?

Thanks,

Igor.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad Data Point - General
notifications altogether.

Toad Data Point - Discussion Forum

Flag
this post as spam/abuse.


#5

I used the same special build. I’ll check with support about how to reproduce.

Thanks.

Igor.


#6

I still cannot reproduce on either XP or W7 machines. At the same time, I observed this or similar problem on 2 another machines. I created CR111469 to track this problem.

Igor.


#7

Igor, I’m using a Win 7 Machine and also have this same problem on 3.3 pro. Schedules appear to be running twice. Is there anything I can provide from my end to try to reproduce on yours? Chad King


#8

Let me expand on this. I’m just running a simple email automation for example. When I run it in TDP directly, it works fine. When I set it to scheduler and let it run in batch, this is when it runs into doing everything twice. Let me know if you need anything else.

This is the data from the .tas file below: (I replaced my smpt and email settings with ??? for security purposes)

<?xml version="1.0" encoding="utf-16"?><![CDATA[](http://schemas.quest.com/ToadAutomation/Plugin">)

<ta0:DefaultDescriptionActivity To="???" ProdConnection="{x:Null}" UseProjectManager=“True” LogDir=“C:\Users\cking\AppData\Roaming\Quest Software\Toad Data Point 3.3\Automation” Notes=“Script Attributes” Description=“Script Attributes” TestConnection="{x:Null}" Body="" EmbedSql=“False” Enabled=“True” EmailOnError=“True” RelativePath=“False” SmtpPort=“25” ScriptVersion=“2.34” x:Name=“Test_Email_Chad” Mode=“Test” ScriptName=“Test_Email_Chad” From="???" SmtpServer="???" ContinueOnError=“stopOnError” Authentication=“Version=1,AuthenticationMethod=None” Subject=“Automation Script Error”>

ta0:DefaultDescriptionActivity.AttachmentFiles

<x:Array Type="{x:Type ta0:FileDescription}">

<ta0:FileDescription FileName=“C:\Users\cking\AppData\Roaming\Quest Software\Toad Data Point 3.3\Automation\Script_1.log” Description="" />

</x:Array>

</ta0:DefaultDescriptionActivity.AttachmentFiles>

</ta0:DefaultDescriptionActivity>

<ta0:SendEmailActivity MapiServer="???" x:Name=“ExceptionEmail” Bcc="" To="???" Subject=“Automation Script Error” SmtpServer="???" Description=“Send customized email with or without attachments” BodyFileName="" Cc="" Authentication=“Version=1,AuthenticationMethod=None” From="???" OnError=“stopOnError” Body="">

ta0:SendEmailActivity.AttachmentFiles

<x:Array Type="{x:Type ta0:FileDescription}">

<ta0:FileDescription FileName=“C:\Users\cking\AppData\Roaming\Quest Software\Toad Data Point 3.3\Automation\Script_1.log” Description="" />

</x:Array>

</ta0:SendEmailActivity.AttachmentFiles>

</ta0:SendEmailActivity>

<ta0:SendEmailActivity MapiServer="???" x:Name=“Email_1” Bcc="" To="???" Subject=“Test Email” SmtpServer="???" Description=“Send customized email with or without attachments” BodyFileName="" Cc="" Authentication=“Version=1,AuthenticationMethod=None” From="???" OnError=“stopOnError” Body=“Test Email”>

ta0:SendEmailActivity.AttachmentFiles

<x:Array Type="{x:Type ta0:FileDescription}" />

</ta0:SendEmailActivity.AttachmentFiles>

</ta0:SendEmailActivity>

</ta:ToadAutomationScript>]]>


#9

TDP 3.3 moved to .net 4.0. We are finding other issues with automation and .net 4.0 (but have not seen this one before). In our next release we are requiring .net 4.5 for automation. Unfortunately .net 4.5 cannot be installed on XP. Microsoft is desupporting XP in a couple of months so I do not see any fixes coming for this platform. Do you have a win7 pc to run this on?


#10

Debbie,

Here’s the tricky part. I just loaded .net 4.5 on my Win 7 machine. When I did that, it appears that it fixed the problem on my Win 7 machine and tasks only run once. Now, with that being said, we have a Windows Server 2008 that we have this on as well. I’ve moved the same process over to this server and am now having the issue on the server running these tasks twice from the scheduler. I installed .net 4.5 on this server as well, but to no success. It still has the same “run twice” issue. Any suggestions on a Win Server 2008?


#11

That is tricky. Your .net 4.5 upgrade seems to confirm that the issue is with .net. I am not sure what else can be done. In the Toad BI Suite we stopped using the windows scheduler and wrote our own. This will be available Nov 18 but is only used by the team Server of this suite and not in TDP Base or Pro stand alone.


#12

Unfortunately that’s a major deal, because the entire reason we went to Toad Data point was to utilize the automation capabilities of it and run it on a centralized server. We just bought the product so how do we go about reporting this as a trouble issue to continue to see what options can be done to resolve?


#13

I have to agree with Chad. We are also running Server 2008 r2 and didn’t realize it was going to share the same issue as XP.

Carl Roth|** Corporate
Data Solutions**

Business Intelligence|Communications
|Phone: 972.578.6728|carl.roth@xo.com|

From: chad.king [mailto:bounce-chadking@toadworld.com]

Sent: Wednesday, November 06, 2013 2:05 PM

To: toaddatapoint@toadworld.com

Subject: RE: [Toad Data Point - Discussion Forum] TDP 3.3 is running schedules twice. Running 3.3.0.1543 on XP. If I run interavtively in TDP it runs just once. Did not have issue with 3.2.

RE: TDP 3.3 is running schedules twice. Running 3.3.0.1543 on XP. If I run interavtively in TDP
it runs just once. Did not have issue with 3.2.

Reply by chad.king

Unfortunately that’s a major deal, because the entire reason we went to Toad Data point was to utilize the automation capabilities of it and run it on a centralized server. We just bought the
product so how do we go about reporting this as a trouble issue to continue to see what options can be done to resolve?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad Data Point - General
notifications altogether.

Toad Data Point - Discussion Forum

Flag
this post as spam/abuse.


#14

Let me see if I can reproduce on Server 2008 R2. I enter QAT-1130 for this investigation

I can ask both of you a question. Is it possible to go back to using TDP 3.2? Or is there an enhancement in 3.3 that you need?

Debbie


#15

Carl, do you get the double execution of scripts?


#16

Yes, I was the one that originally raised the issue. Also, I am currently running 3.2, but I need fixes in 3.4 (excel format issues).

Carl Roth|** Corporate
Data Solutions**

Business Intelligence|Communications
|Phone: 972.578.6728|carl.roth@xo.com|

From: Debbie Peabody [mailto:bounce-Debbie_Peabody@toadworld.com]

Sent: Wednesday, November 06, 2013 2:21 PM

To: toaddatapoint@toadworld.com

Subject: RE: [Toad Data Point - Discussion Forum] TDP 3.3 is running schedules twice. Running 3.3.0.1543 on XP. If I run interavtively in TDP it runs just once. Did not have issue with 3.2.

RE: TDP 3.3 is running schedules twice. Running 3.3.0.1543 on XP. If I run interavtively in TDP
it runs just once. Did not have issue with 3.2.

Reply by Debbie Peabody

Carl, do you get the double execution of scripts?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad Data Point - General
notifications altogether.

Toad Data Point - Discussion Forum

Flag
this post as spam/abuse.


#17

Can you send me copy of one of your scripts that has the error all of the time(meaning executing twice). Let me see if there is something about the scripts that might be triggering it.

Also, how do you schedule the scripts? Do you use our Job Scheduler? If so can you try creating a new schedule using the Windows Scheduler UI?


#18

I have tried both ways and I my script is exactly like Chad’s. I tried a simple SMTP script which runs twice.

Carl Roth|** Corporate
Data Solutions**

Business Intelligence|Communications
|Phone: 972.578.6728|carl.roth@xo.com|

From: Debbie Peabody [mailto:bounce-Debbie_Peabody@toadworld.com]

Sent: Wednesday, November 06, 2013 2:33 PM

To: toaddatapoint@toadworld.com

Subject: RE: [Toad Data Point - Discussion Forum] TDP 3.3 is running schedules twice. Running 3.3.0.1543 on XP. If I run interavtively in TDP it runs just once. Did not have issue with 3.2.

RE: TDP 3.3 is running schedules twice. Running 3.3.0.1543 on XP. If I run interavtively in TDP
it runs just once. Did not have issue with 3.2.

Reply by Debbie Peabody

Can you send me copy of one of your scripts that has the error all of the time(meaning executing twice). Let me see if there is something about the scripts that might be triggering it.

Also, how do you schedule the scripts? Do you use our Job Scheduler? If so can you try creating a new schedule using the Windows Scheduler UI?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad Data Point - General
notifications altogether.

Toad Data Point - Discussion Forum

Flag
this post as spam/abuse.


#19

We just purchased so never even used 3.2 before. Plus we have IT people that package this software that will never let me get a package built for an older version.

I really appreciate you looking into this though.

Chad


#20

Yes, my script is as simple as running a test email to myself using SMTP. I also tried setting up the script from TDP, as well as manually outside of TDP and still run into the double scheduling issues.

Chad