Toad World® Forums

TDP 3.6 & IBM Netezza ODBC

I have TOAD TDP 3.6.1.3294 and have installed the IBM Netezza ODBC driver (v7.02.00.43763). I can create a DSN and the connection tests fine, but when I configure the connection in TDP (either as Generic ODBC or as IBM Netezza), I get the following error -

Database Error

[Microsoft][ODBC Driver Manager] The specified DSN contains an architecture mismatch between the Driver and Application

I do not show a driver available to use as a direct connection (non-DSN).\

Thank you for any assistance.

Seems like this might be a 32 bit vs 64 bit problem. Did you install 32 or 64 bit ODBC driver?

Not certain - I will find out and update (I did not do the install personally)

I installed the 6.00.03.20259 64-bit driver and I still get the same error.

We only support 32-bit drivers

After over a year and a half of release, WHY would you still only support a 32-bit driver???!!! That makes ZERO sense at all - especially with a LICENSED product!

Additionally, [mention:c51459804ebd46679755185a35a001ea:e9ed411860ed4f2ba0265705b8793d05], you did not address the core error message itself. If it is NOT a driver issue, then WHAT is the problem?

I got that error message trying to connect via ODBC to a Cache front end to a MUMPS database. I had to try about 6 different drivers until I got the right one. You have the wrong driver. Ask IBM what is the correct driver for accessing your install of Netezza. You should get two answers back (one 32 bit driver and one 64 bit driver). Download the 32 bit one, install it and you should be good.

TDP is a 32-bit app. 32-bit and 64-bit don’t naturally play together. We have looked at moving to 64-bit but that would mean we would stop supporting 32-bit. And I am afraid the whole world isn’t quite ready to move to 32-bit. (close but not all:))

Will the 32-bit Driver connect to a 64-bit installation of the Netezza platform? (I do not yet know if the installation is 32 or 64-bit)

Yes. The bitness needs to match the application that is using the driver.

So until TDP becomes 64-bit, it will never be able to connect to a 64-bit Netezza installation? (One would expect a 64-bit TDP application would be backwards compatible with a 32-bit Netezza installation).

This is not the case. I just said the calling application has to match the driver. Did you install 32-bit driver?

Yes, I loaded the 32-bit driver and the error remains the same. (I even dropped back to the 7.1 driver)

Ok, I got the correct driver installed (after 5 diff versions) by installing Aginity. However, I do not see the same SYSTEM Views in TDP that I see in Aginity, though I am using the exact same login information.

Please post a screenshot. I will have the correct developer review. He won’t be back until Tuesday. Also provide the exact driver version so we can try on our side.

The exact driver version is Netezza P3 IBM 7.0.2_001.

Here are the screenshots - TDP does not provide any way to view the SYSTEM VIEWS - which is different from SYSTEM.Views. As you can see, there are 0 System.Views, but 224 SYSTEM VIEWS. This is with the exact same login credentials and permissions.

This functionality is vitally important.

Thank you

As an update, I can query the data - ex, SELECT TABLENAME,OWNER,CREATEDATE FROM _V_TABLE WHERE OBJTYPE=‘TABLE’ - but I cannot browse the Views like I (I believe) I should be able to.

Let me have our QA check into this. It does look like there is an issue. Is this a multi-schema database? Also what is version of the DB instance?

Yes, it is a multi-schema db and it is v7.0 (I don’t know the specific build).

Additionally, it appears that the functionality to view the underlying SCRIPT is not available for Synonyms either.